summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 12698473..f9d320af 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,9 +1,13 @@
-if DBUS_BUILD_TESTS
-
INCLUDES=-I$(top_srcdir) $(DBUS_TEST_CFLAGS)
-noinst_PROGRAMS= echo-client echo-server
+if DBUS_BUILD_TESTS
+TESTS=echo-client echo-server
+else
+TESTS=
+endif
+
+noinst_PROGRAMS= $(TESTS)
echo_client_SOURCES= \
echo-client.c \
@@ -20,4 +24,3 @@ TEST_LIBS=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la $(top_bu
echo_client_LDADD=$(TEST_LIBS)
echo_server_LDADD=$(TEST_LIBS)
-endif