summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 227f0dba..04df3510 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -70,10 +70,10 @@ dist-hook:
for D in $(TESTDIRS); do \
test -d $(distdir)/$$D || mkdir $(distdir)/$$D || exit 1 ; \
done ; \
- FILES=`$(FIND_TESTS) -o -name "*.in"` ; \
+ FILES=`(cd $(srcdir) && $(FIND_TESTS) -o -name "*.in" -a -not -name Makefile.in)` ; \
for F in $$FILES; do \
echo '-- Disting file '$$F ; \
- cp $$F $(distdir)/$$F || exit 1 ; \
+ cp $(srcdir)/$$F $(distdir)/$$F || exit 1 ; \
done
## copy tests to builddir so that generated tests and static tests