summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorFrederic Back <fredericback@gmail.com>2006-09-29 08:06:14 +0000
committerFrederic Back <fredericback@gmail.com>2006-09-29 08:06:14 +0000
commit9f61b0f1bc9393b6d8b92f62f4b82fb91a5b314b (patch)
treeefdc2134fe3f58a99257522dfda37a04d03d63b6 /setup.py
parent0e94ac3838dffe81e82a2b01e3f94314d0ea67fa (diff)
* Install a desktop entry and an icon
* Minor cleanup in the renderer git-svn-id: file:///home/lennart/svn/public/fring/trunk@50 d0d2c35f-0a1e-0410-abeb-dabff30a67ee
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 10 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index dfdd680..43b606b 100644
--- a/setup.py
+++ b/setup.py
@@ -4,18 +4,24 @@ from os import sep
from distutils.core import setup, Extension
if __name__ == '__main__' :
-
- module = Extension('fringtools',sources = ['src'+sep+'extension'+sep+'fringtools.cpp'])
setup(\
name = "fring",
version = "0.0.1",
license = "GPL",
- description = "Display Disk Usage Visually",
+ description = "Display disk usage visually",
packages = ['fringlib'],
package_dir = {'fringlib': 'src'+sep+'fringlib'},
scripts = ['src'+sep+'fring'],
- ext_modules = [ module ]
+ data_files = [
+ ("share"+sep+"fring", ['AUTHORS','COPYING','TODO','README']),
+ ("share"+sep+"pixmaps", ["src"+sep+"fring.svg"]),
+ ("share"+sep+"applications",['src'+sep+'fring.desktop']),
+ ],
+
+ ext_modules = [
+ Extension('fringtools',sources = ['src'+sep+'extension'+sep+'fringtools.cpp'])
+ ],
)