summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-03-29 22:56:16 +0000
committerLennart Poettering <lennart@poettering.net>2004-03-29 22:56:16 +0000
commit9b2ad3c23def89c7d4195d641a433878d9329660 (patch)
treef9efc108b1f80d25140a9e57d732551ca1f8c2de /Makefile.am
parent9115735709c570347236bccbe34ddc8fe6e6e8dc (diff)
autoconf stuff
git-svn-id: file:///home/lennart/svn/public/fusedav/trunk@5 e35a362c-bbd6-0310-a59f-a4efcb1729c4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..a5c2099
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,40 @@
+# $Id$
+
+# This file is part of fusedav.
+#
+# fusedav is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# fusedav is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with fusedav; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+EXTRA_DIST=bootstrap.sh README LICENSE
+SUBDIRS=src doc
+
+MAINTAINERCLEANFILES = README
+noinst_DATA = README
+
+README:
+ rm -f README
+ $(MAKE) -C doc README
+ cd $(srcdir) && ln -s doc/README README
+
+homepage: all dist
+ test -d $$HOME/homepage/private
+ mkdir -p $$HOME/homepage/private/projects/fusedav
+ cp *.tar.gz $$HOME/homepage/private/projects/fusedav
+ cp doc/README.html doc/style.css $$HOME/homepage/private/projects/fusedav
+ cp $$HOME/homepage/private/projects/fusedav/README.html $$HOME/homepage/private/projects/fusedav/index.html
+
+distcleancheck:
+ @:
+
+.PHONY: homepage distcleancheck