summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..0221fc5
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,28 @@
+# $Id$
+
+# This file is part of fusedav.
+#
+# fusedav is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# fusedav is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with fusedav; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+bin_PROGRAMS=fusedav
+
+fusedav_SOURCES=fusedav.c fusedav.h \
+ statcache.c statcache.h \
+ filecache.c filecache.h \
+ session.c session.h \
+ openssl-thread.c openssl-thread.h
+
+fusedav_CFLAGS = $(AM_CFLAGS) -D_GNU_SOURCE $
+fusedav_LDADD = -lpthread $(NEON_LIBS) $(FUSE_LIBS)