summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-12-24 11:01:24 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-12-24 11:01:24 +0000
commit20372318d9a421f4d01edccec3a80e09db061944 (patch)
tree96c62d99166df37044b4afc7eff79a2cbfc1cc18 /Makefile.am
parent5701e846db35810e932631ad32742576791a8895 (diff)
really fix dist
Original commit message from CVS: really fix dist
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am64
1 files changed, 34 insertions, 30 deletions
diff --git a/Makefile.am b/Makefile.am
index ed18dd73..e7b261f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,51 +5,55 @@ SUBDIRS_DOCS =
endif
if USE_GCONFTOOL
-GCONF_DIR=gconf
+GCONF_DIR = gconf
else
-GCONF_DIR=
+GCONF_DIR =
endif
if BUILD_EXTERNAL
-EXT_DIR=ext
+EXT_DIR = ext
else
-EXT_DIR=
+EXT_DIR =
endif
if BUILD_EXAMPLES
-EXAMPLES_DIR=examples
+EXAMPLES_DIR = examples
else
-EXAMPLES_DIR=
+EXAMPLES_DIR =
endif
-SUBDIRS=gst-libs \
- gst sys $(EXT_DIR) \
- $(EXAMPLES_DIR) \
- tools \
- $(GCONF_DIR) \
- testsuite \
- po \
- common \
- m4 \
- pkgconfig \
+SUBDIRS = \
+ gst-libs \
+ gst sys $(EXT_DIR) \
+ $(EXAMPLES_DIR) \
+ tools \
+ $(GCONF_DIR) \
+ testsuite \
+ po \
+ common \
+ m4 \
+ pkgconfig \
$(SUBDIRS_DOCS)
-DIST_SUBDIRS=ext gst-libs \
- gst sys \
- examples \
- tools \
- gconf \
- testsuite \
- po \
- common \
- m4 \
- pkgconfig
+DIST_SUBDIRS = \
+ gst-libs \
+ gst sys ext \
+ examples \
+ tools \
+ gconf \
+ testsuite \
+ po \
+ common \
+ m4 \
+ pkgconfig \
+ docs
-EXTRA_DIST=gst-plugins.spec depcomp \
- AUTHORS COPYING COPYING.LIB NEWS README RELEASE REQUIREMENTS \
- ChangeLog autogen.sh
+EXTRA_DIST = \
+ gst-plugins.spec depcomp \
+ AUTHORS COPYING COPYING.LIB NEWS README RELEASE REQUIREMENTS \
+ ChangeLog autogen.sh
-DISTCLEANFILES=_stdint.h
+DISTCLEANFILES = _stdint.h
# check that no marshal or enumtypes files are included
# this in turn ensures that distcheck fails for missing .list files which is currently