summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-04-07 21:34:28 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-04-07 21:34:28 +0000
commit2977ffd8cc77c6fc5227ea529bf0d6798b5f5f5e (patch)
treeedd702bdd466d01308616a5315e8ef760a4de89a /Makefile.am
parentbb9387fde2ed651efd313d6ce8fdc2e33f11b6db (diff)
Port some changes from 0.6.0/0.6.1 back to HEAD (.pc files moved to pkg-config/, .m4 file moved from plugins to core)
Original commit message from CVS: Port some changes from 0.6.0/0.6.1 back to HEAD (.pc files moved to pkg-config/, .m4 file moved from plugins to core)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am45
1 files changed, 17 insertions, 28 deletions
diff --git a/Makefile.am b/Makefile.am
index 6c5ae33e..f3036f7e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,34 +16,23 @@ else
EXAMPLES_DIR=
endif
-all-local: gstreamer-libs-@GST_MAJORMINOR@.pc gstreamer-play-@GST_MAJORMINOR@.pc gstreamer-libs-@GST_MAJORMINOR@-uninstalled.pc gstreamer-play-@GST_MAJORMINOR@-uninstalled.pc gst-element-check-@GST_MAJORMINOR@.m4
-
-gstreamer-libs-@GST_MAJORMINOR@.pc: gstreamer-libs.pc gstreamer-libs.pc.in
- cp gstreamer-libs.pc gstreamer-libs-@GST_MAJORMINOR@.pc
-gstreamer-play-@GST_MAJORMINOR@.pc: gstreamer-play.pc gstreamer-play.pc.in
- cp gstreamer-play.pc gstreamer-play-@GST_MAJORMINOR@.pc
-gstreamer-libs-@GST_MAJORMINOR@-uninstalled.pc: gstreamer-libs-uninstalled.pc gstreamer-libs-uninstalled.pc.in
- cp gstreamer-libs-uninstalled.pc gstreamer-libs-@GST_MAJORMINOR@-uninstalled.pc
-gstreamer-play-@GST_MAJORMINOR@-uninstalled.pc: gstreamer-play-uninstalled.pc gstreamer-play-uninstalled.pc.in
- cp gstreamer-play-uninstalled.pc gstreamer-play-@GST_MAJORMINOR@-uninstalled.pc
-gst-element-check-@GST_MAJORMINOR@.m4: gst-element-check.m4
- cp $(srcdir)/gst-element-check.m4 gst-element-check-@GST_MAJORMINOR@.m4
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = \
- gstreamer-libs-@GST_MAJORMINOR@.pc \
- gstreamer-play-@GST_MAJORMINOR@.pc
-
-aclocaldir = $(datadir)/aclocal
-aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
-
-SUBDIRS=gst-libs gst sys $(EXT_DIR) $(EXAMPLES_DIR) tools $(GCONF_DIR) testsuite
-
-DIST_SUBDIRS=gst-libs gst sys ext examples tools gconf testsuite
-
-EXTRA_DIST=gst-plugins.spec depcomp gst-element-check.m4 \
- gstreamer-libs.pc.in gstreamer-libs-uninstalled.pc.in \
- gstreamer-play.pc.in gstreamer-play-uninstalled.pc.in \
+SUBDIRS=gst-libs \
+ gst sys $(EXT_DIR) \
+ $(EXAMPLES_DIR) \
+ tools \
+ $(GCONF_DIR) \
+ testsuite \
+ pkgconfig
+
+DIST_SUBDIRS=gst-libs \
+ gst sys ext \
+ examples \
+ tools \
+ gconf \
+ testsuite \
+ pkgconfig
+
+EXTRA_DIST=gst-plugins.spec depcomp \
AUTHORS COPYING README RELEASE REQUIREMENTS \
ChangeLog autogen.sh common m4