summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sourceforge.net>2008-01-09 13:50:09 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2008-01-09 13:50:09 +0000
commit5266203c4ecb59285f2ac31ff4cc5af5698cce18 (patch)
tree84ac5e7751eea0b490b024ea0c0452d8a864b376 /Makefile.am
parentd21b870f58f77674d6b14000ed3b2a402dbe04a4 (diff)
Makefile.am: Include lcov.mak to allow builging coverage reports. Guard check-torture target like in the other packages.
Original commit message from CVS: * Makefile.am: Include lcov.mak to allow builging coverage reports. Guard check-torture target like in the other packages.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 17f646c2..46c6f5bb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,5 +47,13 @@ include $(top_srcdir)/common/po.mak
check-valgrind:
cd tests/check && make check-valgrind
+if HAVE_GST_CHECK
check-torture:
cd tests/check && make torture
+else
+check-torture:
+ true
+endif
+
+include $(top_srcdir)/common/coverage/lcov.mak
+