summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2005-10-12 03:03:27 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2005-10-12 03:03:27 +0000
commitdd8b6e69629ddc308957e103adea1c0e27f8ec89 (patch)
tree18edc38d64a1af2434aad3985788b7e1b516c32e /Makefile.am
parentf3add756e070eb320c3ca560713ea6137c5c1f93 (diff)
don't build checks if we don't have gstcheck
Original commit message from CVS: don't build checks if we don't have gstcheck
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3ff27cbe..06fdfc38 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,18 +6,26 @@ else
GCONF_DIR =
endif
+if HAVE_CHECK
+SUBDIRS_CHECK = check
+else
+SUBDIRS_CHECK =
+endif
+
ALWAYS_SUBDIRS = \
gst sys ext \
- check docs \
+ docs \
po \
m4 common
SUBDIRS = \
$(ALWAYS_SUBDIRS) \
+ $(SUBDIRS_CHECK) \
$(GCONF_DIR)
DIST_SUBDIRS = \
$(ALWAYS_SUBDIRS) \
+ check \
gconf
EXTRA_DIST = \