summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@noraisin.net>2009-01-28 20:34:40 +0000
committerJan Schmidt <thaytan@noraisin.net>2009-01-28 20:34:40 +0000
commit0037635bf2c9f6e3db0c97425d2b113b6f47fe7f (patch)
treed50e8321bf5a6aa17f69d4daaa4e1217dd7183e8 /configure.ac
parent9cf73bdd8f18505269fa4b6d1d80127945e735b1 (diff)
Rewrite the pulse plugin, conditionally enabling new behaviour with
newer pulseaudio. Fixes: #567794 * Hook pulsesink's volume property up with the stream volume -- not the sink volume in PA. * Read the device description directly from the sink instead of going via the mixer. * Properly implement _reset() methods for both sink and source to avoid deadlocks when shutting down a pipeline. * Replace all simple pa_threaded_mainloop_wait() by proper loops to guarantee that we wait for the right event in case multiple events are fired. While this is not strictly necessary in many cases it certainly is more correct and makes me sleep better at night. * Replace CHECK_DEAD_GOTO macros with proper functions * Extend the number of supported channels to 32 since that is the actual limit in PA. * Get rid of _dispose() methods since we don't need them. * Increase the volume property upper limit of the sink to 1000. * Reset function pointers after we disconnect a stream/context. Better fix for bug 556986. * Reset the state of the element properly if open/prepare fails * Cork the PA stream when the pipeline is paused. This allows the PA * daemon to close audio device on pause and thus save a bit of power. * Set PA stream properties based on GST tags such as GST_TAG_TITLE, GST_TAG_ARTIST, and so on. Signed-off-by: Lennart Poettering <lennart@poettering.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2727448c..b2c35e86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -769,6 +769,18 @@ dnl *** pulseaudio ***
translit(dnm, m, l) AM_CONDITIONAL(USE_PULSE, true)
AG_GST_CHECK_FEATURE(PULSE, [pulseaudio plug-in], pulseaudio, [
AG_GST_PKG_CHECK_MODULES(PULSE, libpulse >= 0.9.8)
+ AG_GST_PKG_CHECK_MODULES(PULSE_0_9_11, libpulse >= 0.9.11)
+ if test x$HAVE_PULSE_0_9_11 = xyes; then
+ AC_DEFINE(HAVE_PULSE_0_9_11, 1, [defined if pulseaudio >= 0.9.11 is available])
+ fi
+ AG_GST_PKG_CHECK_MODULES(PULSE_0_9_12, libpulse >= 0.9.12)
+ if test x$HAVE_PULSE_0_9_12 = xyes; then
+ AC_DEFINE(HAVE_PULSE_0_9_12, 1, [defined if pulseaudio >= 0.9.12 is available])
+ fi
+ AG_GST_PKG_CHECK_MODULES(PULSE_0_9_13, libpulse >= 0.9.13)
+ if test x$HAVE_PULSE_0_9_13 = xyes; then
+ AC_DEFINE(HAVE_PULSE_0_9_13, 1, [defined if pulseaudio >= 0.9.13 is available])
+ fi
])
dnl *** dv1394 ***