summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerabbas@merali.org>2006-05-31 10:31:23 +0000
committerZaheer Abbas Merali <zaheerabbas@merali.org>2006-05-31 10:31:23 +0000
commit1710bee58ad9eecda6c27db3bb7deec9cb13c5c7 (patch)
treef6cf92c9555bdb5a2325e198484cd4e6c9bd3073 /configure.ac
parentc6919694d0bdc28a82a20ab21d59c7dfb9c38b4d (diff)
configure.ac: Detect libiec61883 and set necessary CFLAGS and LIBS for dv1394.
Original commit message from CVS: 2006-05-31 Zaheer Abbas Merali <zaheerabbas at merali dot org> * configure.ac: Detect libiec61883 and set necessary CFLAGS and LIBS for dv1394. * ext/raw1394/Makefile.am: Add CFLAGS. * ext/raw1394/gstdv1394src.c: (gst_dv1394src_iec61883_receive), New method, to receive using libiec61883. (gst_dv1394src_iso_receive), #ifdef'd out if libiec61883 is present. (gst_dv1394src_bus_reset), Get userdata correctly if using libiec61883. (gst_dv1394src_create), When using libiec61883, only poll one fd and no need to read. (gst_dv1394src_discover_avc_node), Replace g_warnings. (gst_dv1394src_start), Create new handle when we know which dv port. More reliable than setting port on an existing handle. Initialise libiec61883. (gst_dv1394src_stop): If using libiec61883, then cleanup its handle properly. * ext/raw1394/gstdv1394src.h: Add libiec61883 handle.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1aa1fd97..de44ceed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -582,17 +582,25 @@ GST_CHECK_FEATURE(DV1394, [raw1394 and avc1394 library], dv1394src, [
GST_CHECK_LIBHEADER(ROM1394,
rom1394, rom1394_free_directory, $RAW1394_LIBS,
libavc1394/rom1394.h, ROM1394_LIBS="-lrom1394")
-
+ PKG_CHECK_MODULES(LIBIEC61883, libiec61883 >= 1.0.0, HAVE_LIBIEC61883="yes",
+ HAVE_LIBIEC61883="no")
dnl now see how far we got
if test x$HAVE_RAW1394 = xyes && \
test x$HAVE_AVC1394 = xyes && \
test x$HAVE_ROM1394 = xyes; then
HAVE_DV1394=yes
DV1394_LIBS="$RAW1394_LIBS $AVC1394_LIBS $ROM1394_LIBS"
+ DV1394_CFLAGS=""
+ if test x$HAVE_LIBIEC61883 = xyes; then
+ DV1394_CFLAGS="$LIBIEC61883_CFLAGS -DHAVE_LIBIEC61883"
+ DV1394_LIBS="$DV1394_LIBS $LIBIEC61883_LIBS"
+ fi
+ AC_SUBST(DV1394_CFLAGS)
AC_SUBST(DV1394_LIBS)
else
HAVE_DV1394=no
fi
+
])
dnl *** shout2 ***