summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKwang Yul Seo <kwangyul.seo@gmail.com>2007-12-09 05:02:17 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2007-12-09 05:02:17 +0000
commit1e28a6937131f4b09be6464aefe3dbfbeef89086 (patch)
tree708a1381d51b3f211930d9560622e8b5ae45b420 /configure.ac
parent7ea8f11b9a2ff2f78003c7e0ad400800552533d0 (diff)
Fix compilation with MSVC by using gst_util_guint64_to_gdouble() and checking for rint() and implementing it ourself ...
Original commit message from CVS: Based on a patch by: Kwang Yul Seo <kwangyul dot seo at gmail dot com> * configure.ac: * ext/cairo/gsttimeoverlay.c: (gst_cairo_time_overlay_print_smpte_time): Fix compilation with MSVC by using gst_util_guint64_to_gdouble() and checking for rint() and implementing it ourself if it doesn't exist.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 592e4a25..286161b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -218,6 +218,11 @@ AC_C99_FUNC_LRINTF
dnl *** checks for library functions ***
+LIBS_SAVE=$LIBS
+LIBS="$LIBS $LIBM"
+AC_CHECK_FUNCS(rint)
+$LIBS=$LIB_SAVE
+
dnl Check for mmap (needed by electricfence plugin)
AC_FUNC_MMAP
AM_CONDITIONAL(GST_HAVE_MMAP, test "x$ac_cv_func_mmap_fixed_mapped" == "xyes")