summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2002-08-13 10:39:26 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2002-08-13 10:39:26 +0000
commit2ac6c03fb1834bb78ee7150eed08fa8a8aa91413 (patch)
treea829d627f44129990d1c7cdc72566b0cf31b45fe /configure.ac
parent1f82b1e46152b5994460a2b8d91461d82e9ca8ad (diff)
closes http://bugzilla.gnome.org/show_bug.cgi?id=87453 please test this and let me know if it works or not !
Original commit message from CVS: closes http://bugzilla.gnome.org/show_bug.cgi?id=87453 please test this and let me know if it works or not !
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 4 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index cfc7464f..b66f47d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -207,6 +207,7 @@ AC_SUBST(X_LIBS)
dnl ===========================================================================
dnl ============================= gst plug-ins ================================
dnl ===========================================================================
+
GST_PLUGIN_LDFLAGS='-module -avoid-version'
AC_SUBST(GST_PLUGIN_LDFLAGS)
@@ -227,7 +228,7 @@ if test "x$HAVE_CXX" = "xyes"; then
GST_PLUGINS_ALL="$GST_PLUGINS_ALL \
modplug"
else
- echo "Not compiling plug-ins requiring C++ compiler"
+ AC_MSG_WARN([Not compiling plug-ins requiring C++ compiler])
fi
AC_SUBST(GST_PLUGINS_ALL)
@@ -409,15 +410,9 @@ GST_CHECK_FEATURE(AUDIOFILE, [audiofile], afsink afsrc, [
])
dnl *** avifile ***
-dnl this check uses the GST_CHECK_CONFIGPROG macro
-dnl this check needs more fixing
-dnl translit(dnm, m, l) AC_SUBST(AVIFILE_LIBS)
translit(dnm, m, l) AM_CONDITIONAL(USE_AVIFILE, true)
-GST_CHECK_FEATURE(AVIFILE, [avifile], windec winenc, [
- translit(dnm, m, l) AC_SUBST(AVIFILE_CFLAGS)
- GST_CHECK_CONFIGPROG(AVIFILE, avifile-config)
- AVIFILE_LIBS="$AVIFILE_LIBS -lstdc++"
- AC_SUBST(AVIFILE_LIBS)
+GST_CHECK_FEATURE(AVIFILE, [avifile], winenc windec, [
+ AS_AVIFILE(0.7.0)
])
dnl *** CDParanoia ***