summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2006-03-17 15:33:08 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-03-17 15:33:08 +0000
commit33daa1ef853f40975b45a7a88d26416373e0ed26 (patch)
tree83177549750172b02d3755b34ce624f9a2fcfa4f /configure.ac
parentff2c5fd49cc302de2f2732b91768cd2c2e5f199a (diff)
configure.ac: Don't compile udp and rtsp plugins on win32 (mingw) or other systems that don't have <sys/socket.h> for...
Original commit message from CVS: * configure.ac: Don't compile udp and rtsp plugins on win32 (mingw) or other systems that don't have <sys/socket.h> for some reason (#316203).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6a2befe6..1cb417fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -111,6 +111,18 @@ AC_ARG_WITH(plugins,
done],
[GST_PLUGINS_SELECTED=$GST_PLUGINS_ALL])
+dnl disable gst plugins we might not be able to build on this
+dnl platform: udp and rtsp (ugly but minimally invasive)
+AC_CHECK_HEADERS([sys/socket.h], HAVE_SYS_SOCKET_H=yes)
+AM_CONDITIONAL(HAVE_SYS_SOCKET_H, test "x$HAVE_SYS_SOCKET_H" = "xyes")
+
+if test "x$HAVE_SYS_SOCKET_H" != "xyes"; then
+ GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | $(SED) -e s/udp//`
+ GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | $(SED) -e s/rtsp//`
+ GST_PLUGINS_NO="\tudp\n$GST_PLUGINS_NO"
+ GST_PLUGINS_NO="\trtsp\n$GST_PLUGINS_NO"
+fi
+
AC_SUBST(GST_PLUGINS_SELECTED)
dnl ext plug-ins; plug-ins that have external dependencies