summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2007-06-08 20:19:55 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2007-06-08 20:19:55 +0000
commit4e78ffa15ca12b06a2629b0f280b75dfd1cd07bc (patch)
treed1627a7c48511e534539a1146489aecf6e9803aa /configure.ac
parentc0b48c47d0b611291179d517316583b1d5d13300 (diff)
move wavpack plugin. See #352605.
Original commit message from CVS: * configure.ac: * docs/plugins/Makefile.am: * docs/plugins/gst-plugins-good-plugins-docs.sgml: * docs/plugins/gst-plugins-good-plugins-sections.txt: * docs/plugins/gst-plugins-good-plugins.args: * docs/plugins/gst-plugins-good-plugins.hierarchy: * docs/plugins/gst-plugins-good-plugins.signals: * docs/plugins/inspect/plugin-autodetect.xml: * docs/plugins/inspect/plugin-gconfelements.xml: * docs/plugins/inspect/plugin-ladspa.xml: * docs/plugins/inspect/plugin-rtp.xml: * docs/plugins/inspect/plugin-wavpack.xml: * ext/Makefile.am: * tests/check/Makefile.am: move wavpack plugin. See #352605.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a22cbaa..9ba370e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -216,6 +216,9 @@ dnl *** checks for header files ***
dnl check if we have ANSI C header files
AC_HEADER_STDC
+dnl used by ext/wavpack
+AX_CREATE_STDINT_H
+
dnl used in gst/rtp/gstasteriskh263.c
AC_CHECK_HEADERS([netinet/in.h])
AC_CHECK_HEADERS([winsock2.h])
@@ -849,6 +852,22 @@ AG_GST_CHECK_FEATURE(TAGLIB, [taglib tagging library], taglib, [
fi
])
+dnl *** wavpack ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_WAVPACK, true)
+AG_GST_CHECK_FEATURE(WAVPACK, [wavpack plug-in], wavpack, [
+ PKG_CHECK_MODULES(WAVPACK, wavpack >= 4.40.0, HAVE_WAVPACK=yes, [
+ PKG_CHECK_MODULES(WAVPACK, wavpack >= 4.20, [
+ HAVE_WAVPACK=yes
+ AC_DEFINE(WAVPACK_OLD_API, 1, [old wavpack API])
+ ],[
+ HAVE_WAVPACK=no
+ AC_MSG_RESULT(no)
+ ])
+ ])
+ AC_SUBST(WAVPACK_CFLAGS)
+ AC_SUBST(WAVPACK_LIBS)
+])
+
dnl *** id3demux prefers to have zlib ***
translit(dnm, m, l) AM_CONDITIONAL(USE_ZLIB, true)
AG_GST_CHECK_FEATURE(ZLIB, [zlib support for id3demux],, [
@@ -890,6 +909,7 @@ AM_CONDITIONAL(USE_DV1394, false)
AM_CONDITIONAL(USE_SHOUT2, false)
AM_CONDITIONAL(USE_SPEEX, false)
AM_CONDITIONAL(USE_TAGLIB, false)
+AM_CONDITIONAL(USE_WAVPACK, false)
AM_CONDITIONAL(USE_ZLIB, false)
fi dnl of EXT plugins
@@ -990,6 +1010,7 @@ ext/raw1394/Makefile
ext/shout2/Makefile
ext/speex/Makefile
ext/taglib/Makefile
+ext/wavpack/Makefile
sys/Makefile
sys/directdraw/Makefile
sys/directsound/Makefile