summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim.muller@collabora.co.uk>2009-05-22 01:10:12 +0100
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2009-05-22 01:31:47 +0100
commit5776632762d88a3e90fd81300ca7124ad5ab0f3f (patch)
tree2875a1d9a90ec1b0241dee619c5637e6ada31020 /configure.ac
parent67bcdf2d0b7bb4d4e66ecb8d4047f10f490a0870 (diff)
m4: fix 'suspicious cache id' warnings
and update common to pull in a similar fix. Also check in configure whether the compiler supports do while macros (GLib wants this defined and it is needed to avoid warnings with some c++ compilers apparently).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index efea029f..bfe13151 100644
--- a/configure.ac
+++ b/configure.ac
@@ -116,6 +116,9 @@ AM_PROG_CC_C_O
dnl find an assembler
AM_PROG_AS
+dnl check if the compiler supports do while(0) macros
+AG_GST_CHECK_DOWHILE_MACROS
+
AC_PATH_PROG(VALGRIND_PATH, valgrind, no)
AM_CONDITIONAL(HAVE_VALGRIND, test ! "x$VALGRIND_PATH" = "xno")