summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Matthew <jonathan@d14n.org>2009-01-26 09:51:36 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2009-01-26 09:55:24 +0100
commit5a0e94b8a75be2e59617af31326bd5defaab0ac5 (patch)
treee1c91c31ad4fc97076aed575a4f2e7691fb3eed8 /configure.ac
parent66de4c1bba5b2da9a50218e0f84071a10385e28e (diff)
Use libsoup-gnome for proxy configuration if available
If libsoup-gnome is found use this as it will give us the GNOME proxy configuration. Otherwise use normal libsoup. The GNOME proxy configuration will only be used if the proxy properties are not set on souphttpsrc and if the http_proxy environment variable is not set. Fixes bug #552140.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0f11fb36..2727448c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -836,9 +836,14 @@ AG_GST_CHECK_FEATURE(SHOUT2, [Shoutcast/Icecast client library], shout2, [
dnl *** soup ***
translit(dnm, m, l) AM_CONDITIONAL(USE_SOUP, true)
AG_GST_CHECK_FEATURE(SOUP, [soup http client plugin (2.4)], souphttpsrc, [
- PKG_CHECK_MODULES(SOUP, libsoup-2.4 >= 2.3.2, HAVE_SOUP="yes", [
- HAVE_SOUP="no"
- AC_MSG_RESULT(no)
+ PKG_CHECK_MODULES(SOUP, libsoup-gnome-2.4 >= 2.3.2, [
+ HAVE_SOUP="yes"
+ AC_DEFINE(HAVE_LIBSOUP_GNOME, 1, [soup gnome integration])
+ ],[
+ PKG_CHECK_MODULES(SOUP, libsoup-2.4 >= 2.3.2, HAVE_SOUP="yes", [
+ HAVE_SOUP="no"
+ AC_MSG_RESULT(no)
+ ])
])
AC_SUBST(SOUP_CFLAGS)
AC_SUBST(SOUP_LIBS)