summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-08-12 12:00:31 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-08-12 12:00:31 +0000
commit5e90cd810cdec082739c103607ea4cb44c7a2ec4 (patch)
tree7aafe50310ca37a7b23359f647bae714f50a647e /configure.ac
parent93d30f57206afb5e74a9c402ed090e1e1e405675 (diff)
set origin and package name
Original commit message from CVS: set origin and package name
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6ffc6b68..25525cf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1776,6 +1776,7 @@ dnl ############################
dnl set license and copyright notice
AC_DEFINE(GST_LICENSE, "LGPL", [GStreamer license])
+
dnl package name in plugins
AC_ARG_WITH(package-name,
AC_HELP_STRING([--with-package-name],[specify package name to use in plugins]),
@@ -1784,9 +1785,20 @@ AC_HELP_STRING([--with-package-name],[specify package name to use in plugins]),
no) AC_MSG_ERROR(bad value ${withval} for --with-package-name) ;;
*) GST_PACKAGE="${withval}" ;;
esac],
-[GST_PACKAGE="GStreamer Plugins"]) dnl Default value
+[
+dnl default value
+if test "x$GST_CVS" = "xyes"
+then
+ dnl nano >= 1
+ GST_PACKAGE="GStreamer CVS/prerelease"
+else
+ GST_PACKAGE="GStreamer source release"
+fi
+]
+)
AC_MSG_NOTICE(Using $GST_PACKAGE as package name)
AC_DEFINE_UNQUOTED(GST_PACKAGE, "$GST_PACKAGE", [package name in plugins])
+
dnl package origin URL
AC_ARG_WITH(package-origin,
AC_HELP_STRING([--with-package-origin],[specify package origin URL to use in plugins]),
@@ -1795,7 +1807,7 @@ AC_HELP_STRING([--with-package-origin],[specify package origin URL to use in plu
no) AC_MSG_ERROR(bad value ${withval} for --with-package-origin) ;;
*) GST_ORIGIN="${withval}" ;;
esac],
-[GST_ORIGIN="http://gstreamer.net/"]) dnl Default value
+[GST_ORIGIN="http://gstreamer.freedesktop.org/"]) dnl Default value
AC_MSG_NOTICE(Using $GST_ORIGIN as package origin)
AC_DEFINE_UNQUOTED(GST_ORIGIN, "$GST_ORIGIN", [package origin])