summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2006-05-02 13:24:38 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2006-05-02 13:24:38 +0000
commit7df5ab1bf288e8648c5e2be8b80517783e69de5a (patch)
tree2d39c55c23b5d0fb0cab0674b0f5f1962d2087e4 /configure.ac
parentbaf4e3eb080478e0e19cac446712043ee7a8b0fb (diff)
configure.ac: figure out where plugins-base plugins are
Original commit message from CVS: * configure.ac: figure out where plugins-base plugins are * tests/check/Makefile.am: use plugins-base plugins, so we have typefind functions * tests/check/elements/id3v2mux.c: (test_taglib_id3mux_with_tags): increase num-buffers, this makes sure the test errors out instead of timing out when no typefind functions are present
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 500c9910..492bccc0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -242,6 +242,10 @@ if test -z $GST_TOOLS_DIR; then
fi
AC_SUBST(GST_TOOLS_DIR)
+GSTPB_PLUGINS_DIR=`$PKG_CONFIG gstreamer-plugins-base-$GST_MAJORMINOR --variable pluginsdir`
+AC_SUBST(GSTPB_PLUGINS_DIR)
+AC_MSG_NOTICE(Using GStreamer Base Plugins in $GSTPB_PLUGINS_DIR)
+
dnl FIXME: get rid of this by making sure gstreamer-check brings it in
dnl check for "check", unit testing library/header
AM_PATH_CHECK(0.9.2, HAVE_CHECK=yes, HAVE_CHECK=no)