summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerabbas@merali.org>2004-06-22 06:27:37 +0000
committerZaheer Abbas Merali <zaheerabbas@merali.org>2004-06-22 06:27:37 +0000
commit87b46cf1225eff3b45806d81a829d5fbd1af4365 (patch)
tree6bfc5dbb7396fc67c0145f27cdebf0ea3181ce73 /configure.ac
parentfa950fe235dfdd0c206efb0291c012a7773e31dd (diff)
configure.ac: Whoops, my fault...fixed build issues
Original commit message from CVS: 2004-06-22 Zaheer Abbas Merali <zaheerabbas at merali.org> * configure.ac: Whoops, my fault...fixed build issues
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8560dec2..d7f52d2a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,9 +44,9 @@ AM_PROG_CC_STDC
AM_PROG_AS
AS="${CC}"
dnl objective-c for OSX (should check if os is darwin)
+AM_CONDITIONAL([am__fastdepOBJC], false)
case "$host" in
*-*darwin*)
- AM_CONDITIONAL([am__fastdepOBJC], false)
OBJC="${CC}"
AC_SUBST(OBJC)
OBJCFLAGS="${CFLAGS}"
@@ -489,11 +489,16 @@ GST_CHECK_FEATURE(OSX_AUDIO, [OSX audio], osxaudiosrc osxaudiosink, [
dnl *** OS X video ***
translit(dnm, m, l) AM_CONDITIONAL(USE_OSX_VIDEO, true)
HAVE_OSX_VIDEO="no"
+GST_CHECK_FEATURE(OSX_VIDEO, [OSX video], osxvideosink, [
+ AC_CHECK_HEADER(OpenGL/gl.h, HAVE_OSX_VIDEO="yes", HAVE_OSX_VIDEO="no")
+])
+dnl in case header OpenGL/gl.h is found on other platforms
case "$host" in
*-*darwin*)
- GST_CHECK_FEATURE(OSX_VIDEO, [OSX video], osxvideosink, [
- AC_CHECK_HEADER(OpenGL/gl.h, HAVE_OSX_VIDEO="yes", HAVE_OSX_VIDEO="no")
- ])
+ dnl do nothing
+ ;;
+ *)
+ HAVE_OSX_VIDEO="no"
;;
esac