summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2006-05-01 11:46:33 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2006-05-01 11:46:33 +0000
commit8d58b030d62888b25efa032fb7dba368730704b0 (patch)
tree300f444b9e9210ab3ccf2ef40d4447f0c7b2ade4 /configure.ac
parenta4ddb7b60a7a0750de0b80a47d6cbe1b41b71f3a (diff)
docs/plugins/Makefile.am: also check .cc files for gtk-doc markup
Original commit message from CVS: * docs/plugins/Makefile.am: also check .cc files for gtk-doc markup * configure.ac: * docs/plugins/gst-plugins-good-plugins-docs.sgml: * docs/plugins/gst-plugins-good-plugins-sections.txt: * tests/check/Makefile.am: * tests/check/elements/id3v2mux.c: (id3v2mux_suite), (main): * ext/Makefile.am: * ext/taglib/Makefile.am: * ext/taglib/gstid3v2mux.h: * ext/taglib/gsttaglibmux.c: * ext/taglib/gsttaglibmux.h: move taglib-based id3v2muxer to -good. Fixes #336110.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ede1f4eb..500c9910 100644
--- a/configure.ac
+++ b/configure.ac
@@ -651,6 +651,21 @@ GST_CHECK_FEATURE(SPEEX, [speex plug-in], speex, [
])
])
+dnl *** taglib ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_TAGLIB, true)
+GST_CHECK_FEATURE(TAGLIB, [taglib ID3v2 tag writer], taglib, [
+ PKG_CHECK_MODULES(TAGLIB, taglib >= 1.4, HAVE_TAGLIB="yes", [
+ HAVE_TAGLIB="no"
+ AC_MSG_RESULT(no)
+ ])
+ AC_SUBST(TAGLIB_CFLAGS)
+ AC_SUBST(TAGLIB_LIBS)
+ if test "x$HAVE_CXX" != "xyes"; then
+ USE_TAGLIB=false
+ AC_MSG_NOTICE([Not building taglib plugin: no C++ compiler found])
+ fi
+])
+
dnl *** id3demux prefers to have zlib ***
translit(dnm, m, l) AM_CONDITIONAL(USE_ZLIB, true)
GST_CHECK_FEATURE(ZLIB, [zlib support for id3demux],, [
@@ -757,6 +772,7 @@ ext/libpng/Makefile
ext/raw1394/Makefile
ext/shout2/Makefile
ext/speex/Makefile
+ext/taglib/Makefile
sys/Makefile
sys/oss/Makefile
sys/sunaudio/Makefile