summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFilippo Argiolas <filippo.argiolas@gmail.com>2009-07-03 08:38:43 +0200
committerFilippo Argiolas <filippo.argiolas@gmail.com>2009-07-13 16:16:05 +0200
commit946c20a8ba9d5266b45378c38f2882352c65b79d (patch)
tree0b5a1b8137deed471b1680978f4663c720f5ab40 /configure.ac
parent91ad86c0f951e72a25265e7f16e50725a1ea546e (diff)
v4l2src: optional support for device probing with gudev
Enumerate v4l2 devices using gudev if available. Fixes bug #583640.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb9bbf89..c43d7707 100644
--- a/configure.ac
+++ b/configure.ac
@@ -508,6 +508,29 @@ return 0;
fi
])
+# Optional gudev for device probing
+AC_ARG_WITH([gudev],
+ AC_HELP_STRING([--with-gudev],
+ [device detection with gudev]),
+ [],
+ [with_gudev=check])
+if test x$HAVE_GST_V4L2 = xyes; then
+ if test x$with_gudev != xno; then
+ PKG_CHECK_MODULES(GUDEV, [ gudev-1.0 >= 143 ],
+ [ have_gudev=yes
+ AC_DEFINE(HAVE_GUDEV, 1,
+ [Whether gudev is available for device detection])
+ AC_DEFINE([G_UDEV_API_IS_SUBJECT_TO_CHANGE], 1, [I know the API is subject to change.])
+ ], [
+ have_gudev=no
+ ])
+ else
+ have_gudev=no
+ fi
+fi
+AC_SUBST(GUDEV_CFLAGS)
+AC_SUBST(GUDEV_LIBS)
+
# Make libv4l2 non-automagic
AC_ARG_WITH([libv4l2],
AC_HELP_STRING([--with-libv4l2],