summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2002-08-13 11:56:57 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2002-08-13 11:56:57 +0000
commit96a793967771636940d63ef661132f97963dde69 (patch)
treee19c7db3292dc6a86c2b829552874a6ef3d5adac /configure.ac
parenteb3761f8a91251f59a6291d6981263ab08b41aad (diff)
also adding a libstdc++ check explicitly
Original commit message from CVS: also adding a libstdc++ check explicitly
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 76f7513a..80115d93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -412,8 +412,18 @@ GST_CHECK_FEATURE(AUDIOFILE, [audiofile], afsink afsrc, [
dnl *** avifile ***
translit(dnm, m, l) AM_CONDITIONAL(USE_AVIFILE, true)
GST_CHECK_FEATURE(AVIFILE, [avifile], winenc windec, [
- if test "x$HAVE_CXX" = "xyes"; then
- AS_AVIFILE(0.7.0)
+ if test "x$HAVE_CXX" != "xyes"; then
+ AC_MSG_WARN(No C++ compiler found, not compiling avifile plug-ins)
+ HAVE_AVIFILE="no"
+ else
+ dnl check for libstdc++
+ AC_CHECK_LIB(stdc++, cout,
+ [AS_AVIFILE(0.7.0)],
+ [
+ AC_MSG_WARN(You need libstdc++ to compile with avifile)
+ HAVE_AVIFILE="no"
+ ]
+ )
fi
])