summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <jan.schmidt@sun.com>2009-10-09 00:14:07 +0100
committerJan Schmidt <jan.schmidt@sun.com>2009-10-09 00:14:07 +0100
commit993a29a39064e3afe070eb08e99ee50caea66242 (patch)
treec52e705c5821f73daf199f1962c313dd43cf1218 /configure.ac
parentc40cb187627e84db6adb1dcc349f31b5af0f11a9 (diff)
check: Make the level unit test succeed on Solaris 10
Add a configure check for functional isinf() and fpclass(), and use fpclass() where possible when isinf() is not available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e7649140..31378756 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,9 +175,17 @@ dnl *** checks for library functions ***
LIBS_SAVE=$LIBS
LIBS="$LIBS $LIBM"
-AC_CHECK_FUNCS(rint sinh cosh asinh)
+AC_CHECK_FUNCS(rint sinh cosh asinh fpclass)
LIBS=$LIBS_SAVE
+dnl Check whether isinf() is defined by math.h
+AC_CACHE_CHECK([for isinf], ac_cv_have_isinf,
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <math.h>]], [[float f = 0.0; int i=isinf(f)]])],[ac_cv_have_isinf="yes"],[ac_cv_have_isinf="no"]))
+if test "$ac_cv_have_isinf" = "yes"
+then
+ AC_DEFINE(HAVE_ISINF, 1, [Define to 1 if you have the `isinf' function.])
+fi
+
dnl Check for mmap (needed by electricfence plugin)
AC_FUNC_MMAP
AM_CONDITIONAL(GST_HAVE_MMAP, test "x$ac_cv_func_mmap_fixed_mapped" == "xyes")