summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2002-05-10 21:56:15 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2002-05-10 21:56:15 +0000
commita18f44638bdbe6401cd131f9757d39603123f5e4 (patch)
tree8302c3ae9ddce534bd5bc9f3e228d65e49c40dde /configure.ac
parent8ac992ea60dc117c0ca4dcd6305a251ecc1b3c75 (diff)
removing snapshot from the build because we need to fix it adding gconf schema to build and spec
Original commit message from CVS: removing snapshot from the build because we need to fix it adding gconf schema to build and spec
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 83230534..25b22013 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,6 +93,18 @@ else
HAVE_NASM="yes"
fi
+dnl check for gconf
+translit(dnm, m, l) AM_CONDITIONAL(HAVE_GCONF, true)
+AC_PATH_PROG(GCONFTOOL, gconftool-2, no)
+if test x$GCONFTOOL = xno; then
+ AC_MSG_WARN(Not installing GConf schemas)
+ HAVE_GCONF="no"
+else
+ AM_GCONF_SOURCE_2
+ HAVE_GCONF="yes"
+fi
+AC_SUBST(HAVE_GCONF)
+
dnl check for gstreamer; uninstalled is selected preferentially -- see pkg-config(1)
PKG_CHECK_MODULES(GST, gstreamer >= $GST_PLUGINS_MAJOR.$GST_PLUGINS_MINOR.$GST_PLUGINS_MICRO,
HAVE_GST="yes", HAVE_GST="no")
@@ -842,7 +854,6 @@ ext/sdl/Makefile
ext/shout/Makefile
ext/sidplay/Makefile
ext/smoothwave/Makefile
-ext/snapshot/Makefile
ext/vorbis/Makefile
ext/tarkin/Makefile
ext/xmms/Makefile
@@ -856,6 +867,7 @@ gst-libs/gst/floatcast/Makefile
examples/capsfilter/Makefile
examples/Makefile
tools/Makefile
+gconf/Makefile
testsuite/seeking/Makefile
)