summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2008-07-17 14:40:51 +0000
committerTim-Philipp Müller <tim@centricular.net>2008-07-17 14:40:51 +0000
commitadf2c0a4a4f0d3bccb42cd3bbce2ae26cbc4e985 (patch)
treec6348021ef43139fa7b4a6cfcf32eb15a844ac9e /configure.ac
parentf2fb132b9c4b8ed008a3784f6f942119dbd74277 (diff)
Only use -Wno-attributes (which is there to work around a bug in the taglib 1.5 headers) if the c++ compiler actually...
Original commit message from CVS: * configure.ac:: * ext/taglib/Makefile.am:: Only use -Wno-attributes (which is there to work around a bug in the taglib 1.5 headers) if the c++ compiler actually supports it (#543255).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ddb17be2..da521426 100644
--- a/configure.ac
+++ b/configure.ac
@@ -904,6 +904,14 @@ AG_GST_CHECK_FEATURE(TAGLIB, [taglib tagging library], taglib, [
if test "x$HAVE_CXX" != "xyes"; then
USE_TAGLIB=false
AC_MSG_NOTICE([Not building taglib plugin: no C++ compiler found])
+ else
+ dnl work around bug in taglib 1.5 headers, remove once there is a 1.6
+ AS_CXX_COMPILER_FLAG([-Wno-attributes], [
+ TAGLIB_CXXFLAGS="$TAGLIB_CFLAGS -Wno-attributes"
+ ], [
+ TAGLIB_CXXFLAGS="$TAGLIB_CFLAGS"
+ ])
+ AC_SUBST(TAGLIB_CXXFLAGS)
fi
])