summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Kjellerstedt <pkj@axis.com>2008-03-03 13:03:43 +0000
committerPeter Kjellerstedt <pkj@axis.com>2008-03-03 13:03:43 +0000
commitb7938d24ee5c45fcf17b9987bb88f698430c529e (patch)
tree2affb7fb242babdf1cd31612e3e95b664d5b44fb /configure.ac
parentea6cf647fe47a30e5a5a3060d32518eb75268728 (diff)
configure.ac: Move the checks for bison, flex and as to the program section and the check for gcc inline asm to the c...
Original commit message from CVS: * configure.ac: Move the checks for bison, flex and as to the program section and the check for gcc inline asm to the compiler characteristics section.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 15 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index cfe8618d..ea534dd3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,6 +112,13 @@ AS_PROG_OBJC
dnl check if the compiler supports '-c' and '-o' options
AM_PROG_CC_C_O
+dnl find an assembler
+AM_PROG_AS
+
+dnl we require flex and bison for building the goom plugin
+AG_GST_BISON_CHECK
+AG_GST_FLEX_CHECK
+
AC_PATH_PROG(VALGRIND_PATH, valgrind, no)
AM_CONDITIONAL(HAVE_VALGRIND, test ! "x$VALGRIND_PATH" = "xno")
@@ -156,6 +163,14 @@ dnl *** checks for structures ***
dnl *** checks for compiler characteristics ***
+dnl check if we have GCC inline-asm
+AS_GCC_INLINE_ASSEMBLY([HAVE_GCC_ASM=yes], [HAVE_GCC_ASM=no])
+if test x$HAVE_GCC_ASM = xyes ; then
+ AC_DEFINE(HAVE_GCC_ASM, 1,
+ [Define if compiler supports gcc inline assembly])
+fi
+AM_CONDITIONAL(HAVE_GCC_ASM, test "x$HAVE_GCC_ASM" = "xyes")
+
dnl FIXME: check if this is used; was used for floatcast.h in base
dnl Check for fast float to int casting as defined in C99
AC_C99_FUNC_LRINT
@@ -271,18 +286,6 @@ AG_GST_SET_LEVEL_DEFAULT($GST_CVS)
dnl used in examples
AG_GST_DEFAULT_ELEMENTS
-dnl Check for Yacc and Lex for the goom plugin
-AG_GST_BISON_CHECK
-AG_GST_FLEX_CHECK
-AM_PROG_AS
-dnl Check if we have GCC inline-asm
-AS_GCC_INLINE_ASSEMBLY([HAVE_GCC_ASM=yes], [HAVE_GCC_ASM=no])
-if test x$HAVE_GCC_ASM = xyes ; then
- AC_DEFINE(HAVE_GCC_ASM, 1,
- [Define if compiler supports gcc inline assembly])
-fi
-AM_CONDITIONAL(HAVE_GCC_ASM, test "x$HAVE_GCC_ASM" = "xyes")
-
dnl *** plug-ins to include ***
dnl these are all the gst plug-ins, compilable without additional libs