summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2006-06-17 14:35:37 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-06-17 14:35:37 +0000
commitbf9e04e2db0d26cdd7a4343cd41170dc2c6b0b00 (patch)
tree64c41a516718c93059caf3816999457038ae9b23 /configure.ac
parenta5e50a40da7d083b9788767c57a3def2e7a07951 (diff)
configure.ac: Fix --disable-external (can't set conditionals conditionally, #343602).
Original commit message from CVS: * configure.ac: Fix --disable-external (can't set conditionals conditionally, #343602).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f267a818..636061fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -651,6 +651,35 @@ GST_CHECK_FEATURE(ZLIB, [zlib support for id3demux],, [
])
])
+else
+
+dnl not building plugins with external dependencies,
+dnl but we still need to set the conditionals
+AM_CONDITIONAL(USE_GCONFTOOL, false)
+AM_CONDITIONAL(USE_OSS, false)
+AM_CONDITIONAL(USE_SUNAUDIO, false)
+AM_CONDITIONAL(USE_X, false)
+AM_CONDITIONAL(USE_XSHM, false)
+AM_CONDITIONAL(USE_AALIB, false)
+AM_CONDITIONAL(USE_ANNODEX, false)
+AM_CONDITIONAL(USE_CAIRO, false)
+AM_CONDITIONAL(USE_CDIO, false)
+AM_CONDITIONAL(USE_ESD, false)
+AM_CONDITIONAL(USE_FLAC, false)
+AM_CONDITIONAL(USE_GCONF, false)
+AM_CONDITIONAL(USE_GDK_PIXBUF, false)
+AM_CONDITIONAL(USE_HAL, false)
+AM_CONDITIONAL(USE_JPEG, false)
+AM_CONDITIONAL(USE_LADSPA, false)
+AM_CONDITIONAL(USE_LIBCACA, false)
+AM_CONDITIONAL(USE_LIBDV, false)
+AM_CONDITIONAL(USE_LIBPNG, false)
+AM_CONDITIONAL(USE_DV1394, false)
+AM_CONDITIONAL(USE_SHOUT2, false)
+AM_CONDITIONAL(USE_SPEEX, false)
+AM_CONDITIONAL(USE_TAGLIB, false)
+AM_CONDITIONAL(USE_ZLIB, false)
+
fi dnl of EXT plugins
dnl *** finalize CFLAGS, LDFLAGS, LIBS