summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-03-07 13:08:42 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-03-07 13:08:42 +0000
commitc299138aaf5e279b36245c72f5442a7c02a76a5b (patch)
tree9bef76558c168174130f5dbf87df194033f343ba /configure.ac
parent7f9ddba043f5d13378bf512d72880020044e5d17 (diff)
Check for sinh(), cosh() and asinh() and define our own implementations if they're not available. Fixes bug #520880.
Original commit message from CVS: * configure.ac: * gst/audiofx/Makefile.am: * gst/audiofx/audiochebband.c: * gst/audiofx/audiocheblimit.c: * gst/audiofx/math_compat.h: Check for sinh(), cosh() and asinh() and define our own implementations if they're not available. Fixes bug #520880.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ea534dd3..b198f3c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,7 +180,7 @@ dnl *** checks for library functions ***
LIBS_SAVE=$LIBS
LIBS="$LIBS $LIBM"
-AC_CHECK_FUNCS(rint)
+AC_CHECK_FUNCS(rint sinh cosh asinh)
LIBS=$LIBS_SAVE
dnl Check for mmap (needed by electricfence plugin)