summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2008-02-26 10:09:38 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2008-02-26 10:09:38 +0000
commitc34fa140d0c16ce688e42947a8668049ce22cdb7 (patch)
treea33f768a8cdc09adec4cc4e9a678b781ffa48adb /configure.ac
parentc99b95d8cb9f95cd0cec8ad736f139b6029d13c9 (diff)
configure.ac: Detect and indicate if GCC inline assembly syntax is available.
Original commit message from CVS: * configure.ac: Detect and indicate if GCC inline assembly syntax is available. * gst/goom/Makefile.am: * gst/goom/convolve_fx.c: * gst/goom/flying_stars_fx.c: * gst/goom/goom_config.h: * gst/goom/goom_core.c: * gst/goom/goomsl.c: * gst/goom/ifs.c: * gst/goom/mmx.c: * gst/goom/plugin_info.c: * gst/goom/xmmx.c: Fix various GCC-isms, and only build the inline assembly with compilers that support GCC inline assembly. Fix a couple of other warnings shown with Forte.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a6c3170d..1580d75f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -337,6 +337,13 @@ dnl Check for Yacc and Lex for the goom plugin
AG_GST_BISON_CHECK
AG_GST_FLEX_CHECK
AM_PROG_AS
+dnl Check if we have GCC inline-asm
+AS_GCC_INLINE_ASSEMBLY([HAVE_GCC_ASM=yes], [HAVE_GCC_ASM=no])
+if test x$HAVE_GCC_ASM = xyes ; then
+ AC_DEFINE(HAVE_GCC_ASM, 1,
+ [Define if compiler supports gcc inline assembly])
+fi
+AM_CONDITIONAL(HAVE_GCC_ASM, test "x$HAVE_GCC_ASM" = "xyes")
dnl *** sys plug-ins ***