summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Smith <msmith@xiph.org>2008-10-01 21:22:26 +0000
committerMichael Smith <msmith@xiph.org>2008-10-01 21:22:26 +0000
commite2dbf108e6b91a83b66cdd9568c4a27de9ff2bb1 (patch)
tree04a9f3f472214daee88061866b9315b6482b9655 /configure.ac
parent44cb25a34299247d695dec9a9c7881832e54e3ef (diff)
configure.ac: Fix libs for linking directsound.
Original commit message from CVS: * configure.ac: Fix libs for linking directsound. * sys/directsound/gstdirectsoundsink.c: Fix buffer sizing to prevent racing the ringbuffer at startup. Add volume property.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 3 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index 2b3c4f18..785d40de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -394,7 +394,7 @@ AG_GST_CHECK_FEATURE(DIRECTSOUND, [DirectSound plug-in], directsoundsink, [
save_LIBS="$LIBS"
CFLAGS="$CFLAGS $DIRECTSOUND_CFLAGS"
LDFLAGS="$LDFLAGS $DIRECTSOUND_LDFLAGS"
- LIBS="$LIBS -ldsound -ldxerr9"
+ LIBS="$LIBS -ldsound -ldxerr9 -luser32"
AC_MSG_CHECKING(for DirectSound LDFLAGS)
AC_LINK_IFELSE([
#include <windows.h>
@@ -418,7 +418,7 @@ int main ()
if test "x$HAVE_DIRECTSOUND" = "xyes"; then
dnl this is much more than we want
- DIRECTSOUND_LIBS="-ldsound -ldxerr9"
+ DIRECTSOUND_LIBS="-ldsound -ldxerr9 -luser32"
AC_SUBST(DIRECTSOUND_CFLAGS)
AC_SUBST(DIRECTSOUND_LDFLAGS)
AC_SUBST(DIRECTSOUND_LIBS)
@@ -673,38 +673,9 @@ AG_GST_CHECK_FEATURE(ESD, [ESounD sound daemon], esdsink, [
dnl *** FLAC ***
translit(dnm, m, l) AM_CONDITIONAL(USE_FLAC, true)
-AC_TRY_COMPILE([#include <FLAC/export.h>], [
- #if FLAC_API_VERSION_CURRENT < 8
- #error "legacy flac API"
- #endif
- ], [ legacy_flac=no ], [ legacy_flac=yes ], [ legacy_flac=no ])
-
-if test "x$legacy_flac" = "xyes"; then
AG_GST_CHECK_FEATURE(FLAC, [FLAC lossless audio], flac, [
- AG_GST_CHECK_LIBHEADER(FLAC, FLAC, FLAC__seekable_stream_encoder_new, -lm, FLAC/all.h, FLAC_LIBS="-lFLAC -lm")
- dnl API change in FLAC 1.1.1, so require that...
- dnl (this check will also fail with FLAC 1.1.3 which changed API again)
- if test x$HAVE_FLAC = xyes; then
- AC_CHECK_DECL(FLAC__SEEKABLE_STREAM_ENCODER_TELL_ERROR,
- HAVE_FLAC="yes", HAVE_FLAC="no", [
-#include <FLAC/seekable_stream_encoder.h>
- ])
- fi
- AC_SUBST(FLAC_LIBS)
+ AG_GST_PKG_CHECK_MODULES(FLAC, flac >= 1.1.3)
])
-else
-AG_GST_CHECK_FEATURE(FLAC, [FLAC lossless audio], flac, [
- AG_GST_CHECK_LIBHEADER(FLAC, FLAC, FLAC__stream_encoder_new, -lm, FLAC/all.h, FLAC_LIBS="-lFLAC -lm")
- dnl API change in FLAC 1.1.3, so require that...
- if test x$HAVE_FLAC = xyes; then
- AC_CHECK_DECL(FLAC__STREAM_ENCODER_TELL_STATUS_ERROR,
- HAVE_FLAC="yes", HAVE_FLAC="no", [
-#include <FLAC/stream_encoder.h>
- ])
- fi
- AC_SUBST(FLAC_LIBS)
-])
-fi
dnl *** GConf ***
translit(dnm, m, l) AM_CONDITIONAL(USE_GCONF, true)