summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerabbas@merali.org>2004-08-19 22:44:50 +0000
committerZaheer Abbas Merali <zaheerabbas@merali.org>2004-08-19 22:44:50 +0000
commite44aba6128e5481207b0cd5b5c96557e1d7f9d24 (patch)
tree66c36043c4177e0150d2f7f7e65e23c66b17df77 /configure.ac
parent7c336e85adfe67fbfcfb8a22b730e669beb28dfa (diff)
Only enable lame presets if version of lame has presets in API
Original commit message from CVS: 2004-08-19 Zaheer Abbas Merali <zaheerabbas at merali dot org> * configure.ac: * ext/lame/Makefile.am: * ext/lame/gstlame.c: (gst_lame_class_init), (gst_lame_set_property), (gst_lame_get_property), (gst_lame_setup): Only enable lame presets if version of lame has presets in API
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 25525cf1..e491469b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1193,8 +1193,15 @@ GST_CHECK_FEATURE(LADSPA, [ladspa], ladspa, [
dnl *** lame ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LAME, true)
GST_CHECK_FEATURE(LAME, [lame mp3 encoder library], lame, [
- GST_CHECK_LIBHEADER(LAME, mp3lame, lame_init, -lm, lame/lame.h, HAVE_LAME="yes" LAME_LIBS="-lmp3lame")
-])
+ GST_CHECK_LIBHEADER(LAME, mp3lame, lame_init, -lm, lame/lame.h, HAVE_LAME="yes" LAME_LIBS="-lmp3lame -lm")
+])
+dnl is lame presets available
+ac_save_LIBS="$LIBS"
+LIBS="$LAME_LIBS"
+LAME_CFLAGS=""
+AC_CHECK_FUNC(lame_set_preset, LAME_CFLAGS="-DGSTLAME_PRESET",)
+LIBS="$ac_save_LIBS"
+AC_SUBST(LAME_CFLAGS)
AC_SUBST(LAME_LIBS)
dnl *** libcaca ***