summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-07-14 17:37:34 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-07-14 17:37:34 +0000
commit0b1a3a357975e8bbe2281902e5c6f01000aa29dc (patch)
tree64926bf31cb559c5f1acb86f4c6dbb84acddd1f2 /ext/Makefile.am
parentad79edbe4253373a22aca89f3d908c5b86d33470 (diff)
Add matroska support to the build tree
Original commit message from CVS: Add matroska support to the build tree
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 5d8940c7..84326325 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -166,6 +166,12 @@ else
MAD_DIR=
endif
+if USE_MATROSKA
+MATROSKA_DIR=matroska
+else
+MATROSKA_DIR=
+endif
+
if USE_MIKMOD
MIKMOD_DIR=mikmod
else
@@ -264,8 +270,9 @@ SUBDIRS=$(A52DEC_DIR) $(AALIB_DIR) $(ALSA_DIR) \
$(HERMES_DIR) $(JACK_DIR) $(JPEG_DIR) \
$(LADSPA_DIR) $(LAME_DIR) $(LCS_DIR) \
$(LIBDV_DIR) $(LIBFAME_DIR) $(LIBPNG_DIR) \
- $(MAD_DIR) $(MIKMOD_DIR) $(MPEG2DEC_DIR) $(PANGO_DIR) \
- $(RAW1394_DIR) $(SDL_DIR) $(SHOUT_DIR) $(SIDPLAY_DIR) \
+ $(MAD_DIR) $(MATROSKA_DIR) $(MIKMOD_DIR) \
+ $(MPEG2DEC_DIR) $(PANGO_DIR) $(RAW1394_DIR) \
+ $(SDL_DIR) $(SHOUT_DIR) $(SIDPLAY_DIR) \
$(SMOOTHWAVE_DIR) $(SWFDEC_DIR) $(TARKIN_DIR) \
$(VORBIS_DIR) $(XVID_DIR) $(SNAPSHOT_DIR)
@@ -276,7 +283,9 @@ DIST_SUBDIRS=\
flac gdk_pixbuf gnomevfs gsm \
hermes ivorbis jack jpeg \
ladspa lame lcs libfame libpng \
- mad mikmod mpeg2dec pango raw1394 \
- sdl snapshot sndfile shout shout2 sidplay \
+ mad matroska mikmod \
+ mpeg2dec pango raw1394 \
+ sdl snapshot sndfile \
+ shout shout2 sidplay \
smoothwave swfdec tarkin vorbis \
xvid