summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2003-11-24 04:08:47 +0000
committerBenjamin Otte <otte@gnome.org>2003-11-24 04:08:47 +0000
commit1c7db040a3567b460283de2aefccff3046fb2e3d (patch)
tree0c71097d2ec90c65b6a97aea0771b055d5186cc6 /ext/Makefile.am
parent88d6d0d7ba0a905c6d2eca6e4d3b33f8ad1436b9 (diff)
tagging stuff and build fixes. In detail:
Original commit message from CVS: tagging stuff and build fixes. In detail: - make gdk-pixbuf loader work when distchecking - fix invalid syntax in ffmpeg Makefile. wildcards for EXTRA_DIST are not allowed. This broke builds where distdir != srcdir - fix ffmpeg cvs grabbing when srcdir != distdir - new id3tag plugin for id3 tag reading/writing (uses mad's libid3tag) - mad and libid3tag require mad/libid3tag v0.15. Fixed configure to require that - added ogg demuxer in ext/ogg. The demuxer does not handle events yet. Especially getting seeking right will require some effort or code copying from libvorbis. - added raw vorbis detection to typefinding. oggdemux requires a typefind function to detect its contents. - tags plugin in gst/tags. Provides API in <gst/tags/gsttagediting.h>. API includes tag matching GStreamer <=> ID3 and GStreamer <=> vorbis and writing/reading vorbiscomments or ID3v1 tags. Also included is a simple vorbiscomment reader/writer. Writing will not really work though until someone writes oggmux. - various build fixes. Mostly missing (DIST)CLEANFILES. - vorbisenc handles tag writing. Now it's YOUR turn to fix and write more plugins that handle writing/reading of tags. :)
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index d70a37e8..a26660d7 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -196,6 +196,12 @@ else
MPLEX_DIR=
endif
+if USE_OGG
+OGG_DIR=ogg
+else
+OGG_DIR=
+endif
+
if USE_PANGO
PANGO_DIR=pango
else
@@ -313,6 +319,7 @@ SUBDIRS=\
$(MIKMOD_DIR) \
$(MPEG2DEC_DIR) \
$(MPLEX_DIR) \
+ $(OGG_DIR) \
$(PANGO_DIR) \
$(RAW1394_DIR) \
$(SDL_DIR) \
@@ -361,6 +368,7 @@ DIST_SUBDIRS=\
mikmod \
mpeg2dec \
mplex \
+ ogg \
pango \
raw1394 \
sdl \