summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2004-02-20 00:52:07 +0000
committerBenjamin Otte <otte@gnome.org>2004-02-20 00:52:07 +0000
commit3923455478a535d4e61d1b9eefbab2f0ff6fe05c (patch)
treea32113cefb6da2de369f09f5307568f2ac7ed491 /ext/Makefile.am
parent8061a99677e133a5792be2e9f8a02207b871c918 (diff)
ext/xine/: add first version of xine plugin wrapper. Currently only wraps the
Original commit message from CVS: 2004-02-20 Benjamin Otte <otte@gnome.org> * ext/xine/Makefile.am: * ext/xine/gstxine.h: * ext/xine/xine.c: * ext/xine/xineaudiodec.c: * ext/xine/xinecaps.c: add first version of xine plugin wrapper. Currently only wraps the QDM2 win32 DLL, and even that only in proof-of-concept quality. * configure.ac: * ext/Makefile.am: add xine plugin wrapper, disabled by default. Use --enable-xine to build. Note that it'll segfault on gst-register if you don't remove the goom and tvtime post plugins from xine. * gst/qtdemux/qtdemux.c: (gst_qtdemux_handle_sink_event), (qtdemux_parse), (qtdemux_parse_trak), (qtdemux_audio_caps): add extradata parsing for QDM2. change around debugging prints.
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 4865588c..2f51a467 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -310,6 +310,12 @@ else
SPEEX_DIR=
endif
+if USE_XINE
+XINE_DIR=xine
+else
+XINE_DIR=
+endif
+
SUBDIRS=\
$(A52DEC_DIR) \
$(AALIB_DIR) \
@@ -361,6 +367,7 @@ SUBDIRS=\
$(THEORA_DIR) \
$(IVORBIS_DIR) \
$(VORBIS_DIR) \
+ $(XINE_DIR) \
$(XVID_DIR)
DIST_SUBDIRS=\
@@ -415,4 +422,5 @@ DIST_SUBDIRS=\
tarkin \
theora \
vorbis \
+ xine \
xvid