summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2004-01-30 20:23:23 +0000
committerBenjamin Otte <otte@gnome.org>2004-01-30 20:23:23 +0000
commit91f4fb8d2058f18e6daa1985c93c1cfa8af7c372 (patch)
treea008fe768f477a1277880ccdaf5f2abbc1337884 /ext/Makefile.am
parent200b49318f771cf65ab6f759b7b06c1a97f84d41 (diff)
configure.ac: use AC_C_INLINE
Original commit message from CVS: 2004-01-30 Benjamin Otte <in7y118@public.uni-hamburg.de> * configure.ac: use AC_C_INLINE * configure.ac: * ext/Makefile.am: * ext/theora/Makefile.am: * ext/theora/theoradec.c: add theora video decoder. Does just do simple decoding for now and has been tested against Theora cvs only. * ext/vorbis/vorbisdec.c: (vorbis_dec_event): always reset packetno on DISCONT
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 0e091de5..182ac56a 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -298,6 +298,12 @@ else
VORBIS_DIR=
endif
+if USE_THEORA
+THEORA_DIR=theora
+else
+THEORA_DIR=
+endif
+
if USE_XVID
XVID_DIR=xvid
else
@@ -366,6 +372,7 @@ SUBDIRS=\
$(SPEEX_DIR) \
$(SWFDEC_DIR) \
$(TARKIN_DIR) \
+ $(THEORA_DIR) \
$(IVORBIS_DIR) \
$(VORBIS_DIR) \
$(XVID_DIR)
@@ -422,5 +429,6 @@ DIST_SUBDIRS=\
speex \
swfdec \
tarkin \
+ theora \
vorbis \
xvid