summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2003-07-27 05:29:10 +0000
committerDavid Schleef <ds@schleef.org>2003-07-27 05:29:10 +0000
commitc5345b1b8790d1daaadae596b992b2db5805025d (patch)
treee71a44370889a05b4f00d197a205261ea238dd89 /ext/Makefile.am
parentbceeeaadfdca801cb2ca2df9fbcbf785f8c0f327 (diff)
Make mplex subdir dependent on USE_MPLEX
Original commit message from CVS: Make mplex subdir dependent on USE_MPLEX
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 6dacacaf..2b1ab6ec 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -184,6 +184,12 @@ else
MPEG2DEC_DIR=
endif
+if USE_MPLEX
+MPLEX_DIR=mplex
+else
+MPLEX_DIR=
+endif
+
if USE_PANGO
PANGO_DIR=pango
else
@@ -277,7 +283,7 @@ SUBDIRS=$(A52DEC_DIR) $(AALIB_DIR) $(ALSA_DIR) \
$(LADSPA_DIR) $(LAME_DIR) $(LCS_DIR) \
$(LIBDV_DIR) $(LIBFAME_DIR) $(LIBPNG_DIR) \
$(MAD_DIR) $(MATROSKA_DIR) $(MIKMOD_DIR) \
- $(MPEG2DEC_DIR) mplex $(PANGO_DIR) $(RAW1394_DIR) \
+ $(MPEG2DEC_DIR) $(MPLEX_DIR) $(PANGO_DIR) $(RAW1394_DIR) \
$(SDL_DIR) $(SHOUT_DIR) $(SIDPLAY_DIR) \
$(SMOOTHWAVE_DIR) $(SNDFILE_DIR) $(SWFDEC_DIR) $(TARKIN_DIR) \
$(VORBIS_DIR) $(XVID_DIR) $(SNAPSHOT_DIR) $(SPEEX_DIR)