summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-06-25 19:17:59 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-06-25 19:17:59 +0000
commitf40cfecbeea9e78e2b9a9f825898dc0fd17e933f (patch)
treebb875e02570c915042e27d52b26752c3ee36fc56 /ext/Makefile.am
parent9c46a2b631ed238be0548c372d90a3b9f31449b4 (diff)
Plugins cleanup:
Original commit message from CVS: Plugins cleanup: * stereo2mono, mono2stereo, int2float, float2int: replaced by audioconvert. * stereosplit replaced by oneton. * vumeter replaced by level (and was broken anyway). * avifile replaced by ffmpeg. * mjpegtools duplicates functionality of jpeg. jpeg now works with jpeg-mmx, too, which makes mjpegtools unneeded. * allow for jpegmmx instead of jpeg. * openquicktime replaced by qtdemux and ffmpeg. Broken anyway. * XMMS is broken and will never be fixed. * vga is broken and will not be fixed anywhere soon. * videosink has never worked. If it works, add it back to replace xvideosink.
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am33
1 files changed, 6 insertions, 27 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 6bc60b87..c99f71a3 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -172,24 +172,12 @@ else
MIKMOD_DIR=
endif
-if USE_MJPEGTOOLS
-MJPEGTOOLS_DIR=mjpegtools
-else
-MJPEGTOOLS_DIR=
-endif
-
if USE_MPEG2DEC
MPEG2DEC_DIR=mpeg2dec
else
MPEG2DEC_DIR=
endif
-if USE_OPENQUICKTIME
-OPENQUICKTIME_DIR=openquicktime
-else
-OPENQUICKTIME_DIR=
-endif
-
if USE_RAW1394
RAW1394_DIR=raw1394
else
@@ -256,12 +244,6 @@ else
XVID_DIR=
endif
-if USE_XMMS
-XMMS_DIR=xmms
-else
-XMMS_DIR=
-endif
-
if USE_LIBPNG
SNAPSHOT_DIR=snapshot
else
@@ -276,22 +258,19 @@ SUBDIRS=$(A52DEC_DIR) $(AALIB_DIR) $(ALSA_DIR) \
$(HERMES_DIR) $(JACK_DIR) $(JPEG_DIR) \
$(LADSPA_DIR) $(LAME_DIR) $(LCS_DIR) \
$(LIBDV_DIR) $(LIBFAME_DIR) $(LIBPNG_DIR) \
- $(MAD_DIR) $(MIKMOD_DIR) $(MJPEGTOOLS_DIR) $(MPEG2DEC_DIR) \
- $(OPENQUICKTIME_DIR) $(RAW1394_DIR) \
- $(SDL_DIR) $(SHOUT_DIR) $(SIDPLAY_DIR) \
+ $(MAD_DIR) $(MIKMOD_DIR) $(MPEG2DEC_DIR) \
+ $(RAW1394_DIR) $(SDL_DIR) $(SHOUT_DIR) $(SIDPLAY_DIR) \
$(SMOOTHWAVE_DIR) $(SWFDEC_DIR) $(TARKIN_DIR) \
- $(VORBIS_DIR) $(XVID_DIR) $(XMMS_DIR) $(SNAPSHOT_DIR)
+ $(VORBIS_DIR) $(XVID_DIR) $(SNAPSHOT_DIR)
DIST_SUBDIRS=\
- a52dec aalib alsa \
- arts artsd \
+ a52dec aalib alsa arts artsd \
audiofile cdparanoia divx dv \
dvdread dvdnav esd mas ffmpeg \
flac gdk_pixbuf gnomevfs gsm \
hermes ivorbis jack jpeg \
ladspa lame lcs libfame libpng \
- mad mikmod mjpegtools mpeg2dec \
- openquicktime raw1394 \
+ mad mikmod mpeg2dec raw1394 \
sdl snapshot shout shout2 sidplay \
smoothwave swfdec tarkin vorbis \
- xmms xvid
+ xvid