summaryrefslogtreecommitdiffstats
path: root/ext/annodex/Makefile.am
diff options
context:
space:
mode:
authorJulien Moutte <julien@moutte.net>2006-02-25 19:07:41 +0000
committerJulien Moutte <julien@moutte.net>2006-02-25 19:07:41 +0000
commit675a5afed05aa4a67f8eb1ac7ee4b6db96923a7e (patch)
tree07c36573a2f154805b4b1ec11c2d8d5387a0427f /ext/annodex/Makefile.am
parent36e55fc8582b7c256ddf606ff096eafd10c237ab (diff)
Fix a memleak in gst_cmml_track_list_add_clip.
Original commit message from CVS: 2006-02-25 Alessandro Decina <alessandro@nnva.org> * ext/annodex/Makefile.am: * ext/annodex/gstannodex.c: * ext/annodex/gstcmmldec.c: * ext/annodex/gstcmmlenc.c: * ext/annodex/gstcmmlparser.c: * ext/annodex/gstcmmlparser.h: * ext/annodex/gstcmmlutils.c: * tests/check/elements/cmmldec.c: * tests/check/elements/cmmlenc.c: Fix a memleak in gst_cmml_track_list_add_clip. Handle overflows in clip's start and end times. Add the "encoded" parameter to cmmldec and cmmlenc caps. Do not parse junk at the end of a CMML preamble buffer. Register a libxml error handler to not print stuff on stderr. Check for bad clip start and end times in the testsuites.
Diffstat (limited to 'ext/annodex/Makefile.am')
-rw-r--r--ext/annodex/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/ext/annodex/Makefile.am b/ext/annodex/Makefile.am
index b315522d..8c47683d 100644
--- a/ext/annodex/Makefile.am
+++ b/ext/annodex/Makefile.am
@@ -12,8 +12,7 @@ libgstannodex_la_SOURCES = \
gstcmmldec.c \
gstcmmlenc.c \
gstcmmltag.c \
- gstcmmlparser.c \
- gstskeltag.c
+ gstcmmlparser.c
# flags used to compile this plugin
# we use the GST_LIBS flags because we might be using plug-in libs