summaryrefslogtreecommitdiffstats
path: root/ext/annodex/Makefile.am
diff options
context:
space:
mode:
authorMichael Smith <msmith@xiph.org>2006-02-24 19:07:10 +0000
committerMichael Smith <msmith@xiph.org>2006-02-24 19:07:10 +0000
commit73ce8c5b9e9a9cb27c1307dbfee300939265650c (patch)
tree207f645f3849f86026894e7411d9335353a12e53 /ext/annodex/Makefile.am
parentdd8f37faac9ea109550d630f4d7dcbf295cd5fc1 (diff)
Add Annodex elements from Alessendro Decina: skeleton and CMML.
Original commit message from CVS: * configure.ac: * docs/plugins/gst-plugins-good-plugins-sections.txt: * ext/Makefile.am: * ext/annodex/Makefile.am: * ext/annodex/gstannodex.c: * ext/annodex/gstannodex.h: * ext/annodex/gstcmmldec.c: * ext/annodex/gstcmmldec.h: * ext/annodex/gstcmmlenc.c: * ext/annodex/gstcmmlenc.h: * ext/annodex/gstcmmlparser.c: * ext/annodex/gstcmmlparser.h: * ext/annodex/gstcmmltag.c: * ext/annodex/gstcmmltag.h: * ext/annodex/gstcmmlutils.c: * ext/annodex/gstcmmlutils.h: * ext/annodex/gstskeldec.c: * ext/annodex/gstskeldec.h: * ext/annodex/gstskeltag.c: * ext/annodex/gstskeltag.h: * tests/check/Makefile.am: * tests/check/elements/cmmldec.c: * tests/check/elements/cmmlenc.c: * tests/check/elements/skeldec.c: Add Annodex elements from Alessendro Decina: skeleton and CMML. Includes tests & docs, oh my! Passes Thomas's -good checklist entirely. Wow.
Diffstat (limited to 'ext/annodex/Makefile.am')
-rw-r--r--ext/annodex/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/ext/annodex/Makefile.am b/ext/annodex/Makefile.am
new file mode 100644
index 00000000..f4e03883
--- /dev/null
+++ b/ext/annodex/Makefile.am
@@ -0,0 +1,27 @@
+# plugindir is set in configure
+
+# change libgstplugin.la to something more suitable
+plugin_LTLIBRARIES = libgstannodex.la
+
+# for the next set of variables, rename the prefix if you renamed the .la
+
+# sources used to compile this plug-in
+libgstannodex_la_SOURCES = \
+ gstannodex.c \
+ gstcmmlutils.c \
+ gstcmmldec.c \
+ gstcmmlenc.c \
+ gstcmmltag.c \
+ gstcmmlparser.c \
+ gstskeldec.c \
+ gstskeltag.c
+
+# flags used to compile this plugin
+# we use the GST_LIBS flags because we might be using plug-in libs
+libgstannodex_la_CFLAGS = $(GST_CFLAGS) $(XML_CFLAGS)
+libgstannodex_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS) $(XML_LIBS)
+libgstannodex_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+# headers we need but don't want installed
+noinst_HEADERS = gstannodex.h gstcmmlutils.h gstcmmltag.h gstcmmlparser.h \
+ gstcmmldec.h gstskeldec.h gstcmmlenc.h