summaryrefslogtreecommitdiffstats
path: root/ext/annodex/Makefile.am
diff options
context:
space:
mode:
authorJulien Moutte <julien@moutte.net>2006-02-24 23:31:08 +0000
committerJulien Moutte <julien@moutte.net>2006-02-24 23:31:08 +0000
commit7f87731d5bfb572bd1812bd464d168cad26feb5b (patch)
tree30071d959610559119be967bb9884c515e407c0d /ext/annodex/Makefile.am
parent7734c8c65407cd90a835b1e8bc606fb376d5cd63 (diff)
Try to fix Annodex plugin.
Original commit message from CVS: 2006-02-25 Julien MOUTTE <julien@moutte.net> * ext/annodex/Makefile.am: * ext/annodex/gstannodex.c: (plugin_init): * ext/annodex/gstcmmldec.c: * ext/annodex/gstskeldec.c: * ext/annodex/gstskeldec.h: * tests/check/Makefile.am: * tests/check/elements/skeldec.c: Try to fix Annodex plugin.
Diffstat (limited to 'ext/annodex/Makefile.am')
-rw-r--r--ext/annodex/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/ext/annodex/Makefile.am b/ext/annodex/Makefile.am
index f4e03883..b315522d 100644
--- a/ext/annodex/Makefile.am
+++ b/ext/annodex/Makefile.am
@@ -13,15 +13,16 @@ libgstannodex_la_SOURCES = \
gstcmmlenc.c \
gstcmmltag.c \
gstcmmlparser.c \
- gstskeldec.c \
gstskeltag.c
# flags used to compile this plugin
# we use the GST_LIBS flags because we might be using plug-in libs
-libgstannodex_la_CFLAGS = $(GST_CFLAGS) $(XML_CFLAGS)
-libgstannodex_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS) $(XML_LIBS)
+libgstannodex_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_CFLAGS) $(XML_CFLAGS)
+libgstannodex_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) $(GST_BASE_LIBS) \
+ $(GST_LIBS) $(XML_LIBS)
libgstannodex_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
# headers we need but don't want installed
noinst_HEADERS = gstannodex.h gstcmmlutils.h gstcmmltag.h gstcmmlparser.h \
- gstcmmldec.h gstskeldec.h gstcmmlenc.h
+ gstcmmldec.h gstcmmlenc.h