summaryrefslogtreecommitdiffstats
path: root/ext/cairo/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2004-12-16 05:32:07 +0000
committerDavid Schleef <ds@schleef.org>2004-12-16 05:32:07 +0000
commit0163a876c004fc0edd8ca64e9cf5cb72f854b274 (patch)
tree73b5933c6c70335e4b5037e8b6cc08b8e7dabcd3 /ext/cairo/Makefile.am
parent4c750ac9658a0aa08fd6e0a30e6bcb760683f301 (diff)
configure.ac: add audioresample and cairo plugins. Remove
Original commit message from CVS: * configure.ac: add audioresample and cairo plugins. Remove HAVE_MMX stuff, because it's not used. * ext/Makefile.am: same * ext/audioresample/Makefile.am: You are not ready for an audio resampling element based on audioresample. * ext/audioresample/gstaudioresample.c: * ext/audioresample/gstaudioresample.h: * ext/cairo/Makefile.am: You are not ready for overlay elements based on cairo. Don't look too closely, these elements kinda suck right now. * ext/cairo/gstcairo.c: new * ext/cairo/gsttextoverlay.c: new * ext/cairo/gsttextoverlay.h: new * ext/cairo/gsttimeoverlay.c: new * ext/cairo/gsttimeoverlay.h: new * gst-libs/gst/media-info/media-info-priv.h: fix compile problem with compilers that don't support variadic macros.
Diffstat (limited to 'ext/cairo/Makefile.am')
-rw-r--r--ext/cairo/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/ext/cairo/Makefile.am b/ext/cairo/Makefile.am
new file mode 100644
index 00000000..8e80b626
--- /dev/null
+++ b/ext/cairo/Makefile.am
@@ -0,0 +1,14 @@
+
+plugin_LTLIBRARIES = libgstcairo.la
+
+noinst_HEADERS = gsttimeoverlay.h gsttextoverlay.h
+
+libgstcairo_la_SOURCES = \
+ gsttimeoverlay.c \
+ gsttextoverlay.c \
+ gstcairo.c
+libgstcairo_la_CFLAGS = $(GST_CFLAGS) $(CAIRO_CFLAGS) \
+ -I$(top_srcdir)/gst/videofilter
+libgstcairo_la_LIBADD =
+libgstcairo_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(CAIRO_LIBS) -lm
+