summaryrefslogtreecommitdiffstats
path: root/ext/cairo/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2005-11-07 15:09:54 +0000
committerTim-Philipp Müller <tim@centricular.net>2005-11-07 15:09:54 +0000
commit8af7381d5cac93a8af28a303533f34de7aade137 (patch)
tree536e1510dfc741197d86233f11bf7efba2849c7d /ext/cairo/Makefile.am
parentfb1c3904f701a967840cf59cd0808034cfb70d7a (diff)
ext/cairo/: Port cairo textoverlay plugin to 0.9. Add 'shaded-background' property and redo position. Doesn't handle ...
Original commit message from CVS: * ext/cairo/Makefile.am: * ext/cairo/gstcairo.c: (plugin_init): * ext/cairo/gsttextoverlay.c: (gst_text_overlay_base_init), (gst_text_overlay_class_init), (gst_text_overlay_finalize), (gst_text_overlay_init), (gst_text_overlay_font_init), (gst_text_overlay_set_property), (gst_text_overlay_render_text), (gst_text_overlay_getcaps), (gst_text_overlay_setcaps), (gst_text_overlay_text_pad_linked), (gst_text_overlay_text_pad_unlinked), (gst_text_overlay_shade_y), (gst_text_overlay_blit_1), (gst_text_overlay_blit_sub2x2), (gst_text_overlay_push_frame), (gst_text_overlay_pop_video), (gst_text_overlay_pop_text), (gst_text_overlay_collected), (gst_text_overlay_change_state): * ext/cairo/gsttextoverlay.h: Port cairo textoverlay plugin to 0.9. Add 'shaded-background' property and redo position. Doesn't handle upstream renegotiation yet though.
Diffstat (limited to 'ext/cairo/Makefile.am')
-rw-r--r--ext/cairo/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/ext/cairo/Makefile.am b/ext/cairo/Makefile.am
index ecd3e9a9..1951d562 100644
--- a/ext/cairo/Makefile.am
+++ b/ext/cairo/Makefile.am
@@ -3,15 +3,17 @@ plugin_LTLIBRARIES = libgstcairo.la
noinst_HEADERS = gsttimeoverlay.h gsttextoverlay.h
libgstcairo_la_SOURCES = \
+ gstcairo.c \
gsttimeoverlay.c \
- gstcairo.c
-
-# gsttextoverlay.c
+ gsttextoverlay.c
libgstcairo_la_CFLAGS = \
-I$(top_srcdir)/gst/videofilter \
- $(GST_CFLAGS) $(CAIRO_CFLAGS)
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_CFLAGS) $(CAIRO_CFLAGS)
libgstcairo_la_LIBADD = \
$(top_builddir)/gst/videofilter/libgstvideofilter-$(GST_MAJORMINOR).la \
+ $(GST_BASE_LIBS) \
$(GST_LIBS) $(CAIRO_LIBS) -lm
libgstcairo_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)