summaryrefslogtreecommitdiffstats
path: root/ext/cairo/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2005-10-12 03:12:57 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2005-10-12 03:12:57 +0000
commitb51bde9b553764d0d46708089836e182e0f2491c (patch)
treeb4d4c8dccc836c94a47f6ed2723993947931b439 /ext/cairo/Makefile.am
parent722ec5e4ab7e1f3ea020f0ad90cd17347fabe5dc (diff)
ext/: update of cairo-based timeoverlay to 1.0 Cairo API doesn't work yet for resizing of output sink
Original commit message from CVS: * ext/Makefile.am: * ext/cairo/Makefile.am: * ext/cairo/gstcairo.c: (plugin_init): * ext/cairo/gsttextoverlay.c: (gst_textoverlay_change_state): * ext/cairo/gsttimeoverlay.c: (gst_timeoverlay_update_font_height), (gst_timeoverlay_setup), (gst_timeoverlay_planar411): * ext/cairo/gsttimeoverlay.h: update of cairo-based timeoverlay to 1.0 Cairo API doesn't work yet for resizing of output sink
Diffstat (limited to 'ext/cairo/Makefile.am')
-rw-r--r--ext/cairo/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/ext/cairo/Makefile.am b/ext/cairo/Makefile.am
index 92884d53..238f4954 100644
--- a/ext/cairo/Makefile.am
+++ b/ext/cairo/Makefile.am
@@ -1,14 +1,17 @@
-
plugin_LTLIBRARIES = libgstcairo.la
-noinst_HEADERS = gsttimeoverlay.h gsttextoverlay.h
+noinst_HEADERS = gsttimeoverlay.h # gsttextoverlay.h
libgstcairo_la_SOURCES = \
gsttimeoverlay.c \
- gsttextoverlay.c \
gstcairo.c
-libgstcairo_la_CFLAGS = $(GST_CFLAGS) $(CAIRO_CFLAGS) \
- -I$(top_srcdir)/gst/videofilter
-libgstcairo_la_LIBADD = $(GST_LIBS) $(CAIRO_LIBS) -lm
-libgstcairo_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+# gsttextoverlay.c
+
+libgstcairo_la_CFLAGS = \
+ -I$(top_srcdir)/gst/videofilter \
+ $(GST_CFLAGS) $(CAIRO_CFLAGS)
+libgstcairo_la_LIBADD = \
+ $(top_builddir)/gst/videofilter/libgstvideofilter-$(GST_MAJORMINOR).la \
+ $(GST_LIBS) $(CAIRO_LIBS) -lm
+libgstcairo_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)