summaryrefslogtreecommitdiffstats
path: root/ext/dv/Makefile.am
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2005-10-04 17:44:43 +0000
committerEdward Hervey <bilboed@bilboed.com>2005-10-04 17:44:43 +0000
commit3ec9e676e764b773aedd1d50b01cbebe60c31c91 (patch)
treebedd11a7a29d431ca4055f867b6aaa867132662f /ext/dv/Makefile.am
parent05799a15093c4ada8475676b9d53d7c9d19fef28 (diff)
ext/dv/: Added DEFAULT <==> BYTES, TIME conversions on srcpad,
Original commit message from CVS: * ext/dv/Makefile.am: * ext/dv/gstdvdemux.c: (gst_dvdemux_src_query), (gst_dvdemux_src_conver): Added DEFAULT <==> BYTES, TIME conversions on srcpad, Corrected the query function for position so it doesn't forget what format was asked, and calls the conversion functions on the correct pad.
Diffstat (limited to 'ext/dv/Makefile.am')
-rw-r--r--ext/dv/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/ext/dv/Makefile.am b/ext/dv/Makefile.am
index 6352ca58..5afc7f06 100644
--- a/ext/dv/Makefile.am
+++ b/ext/dv/Makefile.am
@@ -1,8 +1,8 @@
plugin_LTLIBRARIES = libgstdv.la
libgstdv_la_SOURCES = gstdv.c gstdvdec.c gstdvdemux.c
-libgstdv_la_CFLAGS = $(GST_CFLAGS) $(LIBDV_CFLAGS)
-libgstdv_la_LIBADD = $(GST_BASE_LIBS) $(LIBDV_LIBS)
+libgstdv_la_CFLAGS = $(GST_CFLAGS) $(LIBDV_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstdv_la_LIBADD = $(GST_BASE_LIBS) $(LIBDV_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-@GST_MAJORMINOR@
libgstdv_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstdvdemux.h gstdvdec.h