summaryrefslogtreecommitdiffstats
path: root/ext/esd/Makefile.am
diff options
context:
space:
mode:
authorRichard Boulton <richard@tartarus.org>2002-03-02 15:20:05 +0000
committerRichard Boulton <richard@tartarus.org>2002-03-02 15:20:05 +0000
commitb6c08a233af79f05c12696f3b2648bf716ad543f (patch)
tree06b8d6f13d84df657fd9a781afc183bfd6b3a849 /ext/esd/Makefile.am
parentff816a14751310025804f4dc5c272f28d075bf6e (diff)
Added esdmon plugin.
Original commit message from CVS: Added esdmon plugin. Monitors output from the esd sound daemon. Particularly useful for displaying a visualisation of the audio being played on your system. eg: gst-launch esdmon ! goom ! { queue leaky=yes ! colorspace ! sdlvideosink } You can even have several of them going at once. :)
Diffstat (limited to 'ext/esd/Makefile.am')
-rw-r--r--ext/esd/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/ext/esd/Makefile.am b/ext/esd/Makefile.am
index 95e7088f..f1a23da6 100644
--- a/ext/esd/Makefile.am
+++ b/ext/esd/Makefile.am
@@ -1,11 +1,16 @@
plugindir = $(libdir)/gst
-plugin_LTLIBRARIES = libesdsink.la
+plugin_LTLIBRARIES = libesdsink.la libesdmon.la
libesdsink_la_SOURCES = esdsink.c
libesdsink_la_CFLAGS = $(GST_CFLAGS) $(ESD_CFLAGS)
libesdsink_la_LIBADD = $(GST_LIBS) $(ESD_LIBS)
libesdsink_la_LDFLAGS = @GST_PLUGIN_LDFLAGS@
+libesdmon_la_SOURCES = esdmon.c
+libesdmon_la_CFLAGS = $(GST_CFLAGS) $(ESD_CFLAGS)
+libesdmon_la_LIBADD = $(GST_LIBS) $(ESD_LIBS)
+libesdmon_la_LDFLAGS = @GST_PLUGIN_LDFLAGS@
+
noinst_HEADERS = esdsink.h
EXTRA_DIST = README