summaryrefslogtreecommitdiffstats
path: root/ext/flac/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-05-25 16:09:39 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-05-25 16:09:39 +0000
commit906f398df7be2972b0713026cb8e735382fc260c (patch)
treeda606c8dab4e101d0319e020163ba47d8bd5895d /ext/flac/Makefile.am
parente7e9e21731a8b479d37e46b2e1b96c315b06c67e (diff)
ext/flac/: Set the channel layout when decoding FLAC files with more than 2 channels as defined by the FLAC spec. Fix...
Original commit message from CVS: * ext/flac/Makefile.am: * ext/flac/gstflacdec.c: (gst_flac_dec_write): Set the channel layout when decoding FLAC files with more than 2 channels as defined by the FLAC spec. Fixes bug #534570. Also don't try to decode left/side, right/side and mid/side files as we don't support this at all.
Diffstat (limited to 'ext/flac/Makefile.am')
-rw-r--r--ext/flac/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/ext/flac/Makefile.am b/ext/flac/Makefile.am
index 982e76f2..2723680e 100644
--- a/ext/flac/Makefile.am
+++ b/ext/flac/Makefile.am
@@ -4,6 +4,7 @@ libgstflac_la_SOURCES = gstflac.c gstflacdec.c gstflacenc.c
libgstflac_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS)
libgstflac_la_LIBADD = \
$(GST_PLUGINS_BASE_LIBS) -lgsttag-$(GST_MAJORMINOR) \
+ -lgstaudio-$(GST_MAJORMINOR) \
$(GST_BASE_LIBS) $(GST_LIBS) $(FLAC_LIBS)
libgstflac_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)