summaryrefslogtreecommitdiffstats
path: root/ext/gconf/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2005-07-20 10:07:10 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2005-07-20 10:07:10 +0000
commit961178077ee2b11f8ccfca69b97527da6ac2750d (patch)
treefd4373131ebef374b1af0e013d4b83c4ec650836 /ext/gconf/Makefile.am
parentbef986dba1998d669af2d95034b4cfd9e3bd1caa (diff)
Port auto/gconfsinks to 0.9. They actually appear to work here in
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/gconf/Makefile.am: * ext/gconf/gconf.c: (gst_bin_find_unconnected_pad), (gst_gconf_render_bin_from_description), (gst_gconf_get_default_video_sink): * ext/gconf/gstgconfaudiosink.c: (gst_gconf_audio_sink_base_init), (gst_gconf_audio_sink_class_init), (gst_gconf_audio_sink_dispose), (cb_toggle_element), (gst_gconf_audio_sink_change_state): * ext/gconf/gstgconfelements.h: * ext/gconf/gstgconfvideosink.c: (gst_gconf_video_sink_base_init), (gst_gconf_video_sink_class_init), (gst_gconf_video_sink_dispose), (cb_toggle_element), (gst_gconf_video_sink_change_state): * gst/autodetect/gstautoaudiosink.c: (gst_auto_audio_sink_base_init), (gst_auto_audio_sink_class_init), (gst_auto_audio_sink_detect), (gst_auto_audio_sink_change_state): * gst/autodetect/gstautovideosink.c: (gst_auto_video_sink_base_init), (gst_auto_video_sink_class_init), (gst_auto_video_sink_find_best), (gst_auto_video_sink_detect): Port auto/gconfsinks to 0.9. They actually appear to work here in Totem as well, making them actually useful.
Diffstat (limited to 'ext/gconf/Makefile.am')
-rw-r--r--ext/gconf/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/ext/gconf/Makefile.am b/ext/gconf/Makefile.am
index 7f0052fb..4e23b174 100644
--- a/ext/gconf/Makefile.am
+++ b/ext/gconf/Makefile.am
@@ -3,15 +3,16 @@ plugin_LTLIBRARIES = libgstgconfelements.la
libgstgconfelements_la_SOURCES = \
gstgconfaudiosink.c \
gstgconfelements.c \
- gstgconfvideosink.c
+ gstgconfvideosink.c \
+ gconf.c
DIR_CFLAGS = -DGST_GCONF_DIR=\"/system/gstreamer/@GST_MAJORMINOR@\"
libgstgconfelements_la_CFLAGS = $(GST_CFLAGS) $(GCONF_CFLAGS) $(DIR_CFLAGS)
-libgstgconfelements_la_LIBADD = $(GCONF_LIBS) \
- $(top_builddir)/gst-libs/gst/gconf/libgstgconf-@GST_MAJORMINOR@.la
+libgstgconfelements_la_LIBADD = $(GCONF_LIBS)
libgstgconfelements_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = \
gstgconfaudiosink.h \
gstgconfelements.h \
- gstgconfvideosink.h
+ gstgconfvideosink.h \
+ gconf.h