summaryrefslogtreecommitdiffstats
path: root/ext/gdk_pixbuf/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2003-12-16 16:58:59 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2003-12-16 16:58:59 +0000
commit7012697bc045a409fcc1582f3485d8e592dda983 (patch)
tree43f9eae388c2c183e6416567a01224c8b314781d /ext/gdk_pixbuf/Makefile.am
parent43e7f73d4b0ba72180279db8be5c923cca3c0e3c (diff)
disable gdk_pixbuf by default
Original commit message from CVS: disable gdk_pixbuf by default
Diffstat (limited to 'ext/gdk_pixbuf/Makefile.am')
-rw-r--r--ext/gdk_pixbuf/Makefile.am15
1 files changed, 6 insertions, 9 deletions
diff --git a/ext/gdk_pixbuf/Makefile.am b/ext/gdk_pixbuf/Makefile.am
index 95477db4..755bd518 100644
--- a/ext/gdk_pixbuf/Makefile.am
+++ b/ext/gdk_pixbuf/Makefile.am
@@ -1,4 +1,3 @@
-
plugin_LTLIBRARIES = libgstgdkpixbuf.la
libgstgdkpixbuf_la_SOURCES = gstgdkpixbuf.c
@@ -11,13 +10,6 @@ if HAVE_GDK_LOADERS
loaderdir = $(DESTDIR)$(GDK_PIXBUF_LOADER_DIR)
loader_LTLIBRARIES = gst_loader.la
-gst_loader_la_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS) -DGDK_PIXBUF_ENABLE_BACKEND
-gst_loader_la_SOURCES = \
- gstgdkanimation.c \
- gst_loader.c
-gst_loader_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) --avoid-version --module
-gst_loader_la_LIBADD = $(GTK_LIBS) $(GST_LIBS)
-
gst_loader_headers = gstgdkanimation.h
install-data-hook:
@@ -25,11 +17,16 @@ install-data-hook:
$(mkinstalldirs) $(DESTDIR)$(GDK_PIXBUF_CONF_DIR) ; \
$(QUERYLOADERS) > $(DESTDIR)$(GDK_PIXBUF_CONF_DIR)/gdk-pixbuf.loaders ; \
fi
-
else
gst_loader_headers =
endif
+gst_loader_la_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS) -DGDK_PIXBUF_ENABLE_BACKEND
+gst_loader_la_SOURCES = \
+ gstgdkanimation.c \
+ gst_loader.c
+gst_loader_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) --avoid-version --module
+gst_loader_la_LIBADD = $(GTK_LIBS) $(GST_LIBS)
noinst_HEADERS = gstgdkpixbuf.h \
$(gst_loader_headers)