summaryrefslogtreecommitdiffstats
path: root/ext/gdk_pixbuf/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2003-11-05 03:24:54 +0000
committerBenjamin Otte <otte@gnome.org>2003-11-05 03:24:54 +0000
commit8468a02e24fa79adc1b396b56e661a3887dfcb52 (patch)
treeb392b760891b093f8d6d9ce74eba551bd93de653 /ext/gdk_pixbuf/Makefile.am
parentbbd6c00598bb1e533011c85ba59cb8f9e0413ab9 (diff)
add initial version of gdkpixbuf loader for gtk that is capable of loading AVI and mpeg videos as GdkPixbufAnimation....
Original commit message from CVS: add initial version of gdkpixbuf loader for gtk that is capable of loading AVI and mpeg videos as GdkPixbufAnimation. I'm not sure if such a thing would be useful or too much trouble, so I'll throw it at enough testers to figure it out ;) We might want to disable it by defualt though in the future. (Currently there is not even a configure switch implemented to disable it.) This includes a fix to not use GError in gstgdkpixbuf's typefind function and to only return GST_TYPE_FIND_MINIMUM when doing typefinding via gdk as this breaks quite a bit with the GStreamer loader installed.
Diffstat (limited to 'ext/gdk_pixbuf/Makefile.am')
-rw-r--r--ext/gdk_pixbuf/Makefile.am25
1 files changed, 24 insertions, 1 deletions
diff --git a/ext/gdk_pixbuf/Makefile.am b/ext/gdk_pixbuf/Makefile.am
index 32e0258e..0e2d82c6 100644
--- a/ext/gdk_pixbuf/Makefile.am
+++ b/ext/gdk_pixbuf/Makefile.am
@@ -6,5 +6,28 @@ libgstgdkpixbuf_la_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS)
libgstgdkpixbuf_la_LIBADD = $(GTK_LIBS)
libgstgdkpixbuf_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstgdkpixbuf.h
+if HAVE_GDK_LOADERS
+loaderdir = $(GTK_BASE_DIR)/lib/gtk-2.0/$(GTK_VERSION)/loaders
+loader_LTLIBRARIES = gst_loader.la
+
+gst_loader_la_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS) -DGDK_PIXBUF_ENABLE_BACKEND
+gst_loader_la_SOURCES = \
+ gstgdkanimation.c \
+ gst_loader.c
+gst_loader_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) --avoid-version --module
+gst_loader_la_LIBADD = $(GTK_LIBS) $(GST_LIBS)
+
+gst_loader_headers = gstgdkanimation.h
+
+install-data-hook:
+ $(mkinstalldirs) $(GTK_BASE_DIR)/etc/gtk-2.0 ; \
+ $(QUERYLOADERS) > $(GTK_BASE_DIR)/etc/gtk-2.0/gdk-pixbuf.loaders ;
+
+else
+gst_loader_headers =
+endif
+
+
+noinst_HEADERS = gstgdkpixbuf.h \
+ $(gst_loader_headers)